Тема 5. Комп'ютерна графіка

За деструктивними можливостями (руйнівною здатністю) віруси можна поділити на: нешкідливі, безпечні, небезпечні, дуже небезпечні.

За алгоритмом роботи розрізняють: віруси–“супутники”,віруси-“червi”, паразитичні, “студентські”, “stealth”, віруси-“примари”, комбіновані віруси.

Для захисту від комп’ютерних вірусів можна використовувати:

1) загальні засоби захисту, що корисні також як страховка від фізичного псування дисків, неправильно працюючих програм чи помилок користувачів;

2) спеціалізовані антивiрусні програми;

3) профілактичні заходи, що дозволяють зменшити імовірність зараження вірусом.

Для захисту від вірусів розробляються спеціальні антивірусні програми, що дозволяють виявляти віруси, лікувати заражені файли і диски, запобігати підозрілим діям.

Залежно від виконуваних функцій серед антивірусних програм виділяють такі: програми-детектори, програми-ревізори, програми-охоронці, програми – лікарі, програми – фільтри, програми - вакцини, антивірусні комплекси.

Антивірусні програми ще можна умовно поділити на:

1) спеціалізовані;

2) універсальні.

Панацеї від комп’ютерних вірусів не існує й існувати не може. Однак дотримання деяких профілактичних заходів дозволяє знизити імовірність тяжких наслідків:

1. Не вставляйте дискети (носії інформації) в будь-який не перевірений на віруси комп’ютер.

2. Не дозволяйте стороннім особам із своїми дискетами (носіями інформації) працювати на вашому комп’ютері.

3. Не передавайте свої дискети (носії інформації) для користування іншим особам.

4. Не користуйтеся випадковими програмами.

5. Спочатку перевірте чужу дискету (носій інформації) на віруси (краще кількома антивірусними програмами).

6. На чужому комп’ютері працюйте після його антивірусної перевірки або з дискетами (носіями інформації), на яких заблокований запис.

7. Робіть періодичні профілактичні перевірки.

8. Перевірте свої дискети на віруси одразу ж після контакту з чужим комп’ютером.

9. На своєму комп’ютері (після кожного завантаження операційної системи) корисно робити попередній антивірусний контроль вінчестера.

10. Необхідно створювати архівні копії найбільш важливої інформації та розподіляти доступ до комп’ютерних систем.

11. Необхідно ретельно і систематично перевіряти дані, що надходять зовні.

12. При лікуванні дисків від вірусів доцільно використовувати завідомо чисту операційну систему, завантажену з дискети.

13. По можливості користуватися законними шляхами одержання програм.

14. Не треба збирати колекції антивiрусних програм невідомого призначення, бо, зокрема, з ними можна отримати новий вірус.



Вид заняття: практичне заняття

Тривалість проведення: 4 г.

Мета занять: Ознайомитись з можливостями сучасних графічних редакторів, навчитись створювати графічні об’єкти та інформаційні презентації.

План практичного заняття:

1. Різновиди комп’ютерної графіки. Переваги та недоліки кожного виду. Графічний редактор Paint. Його вікно. Побудова малюнків, їх редагування, збереження, експорт.

2. Створення презентацій у графічному редакторі PowerPоint for Windows.

Завдання на самостійну підготовку до практичного заняття:

Ознайомитись із рекомендованою літературою, в робочих зошитах занотувати основні положення питань, які надано до розгляду.

Теми рефератів, доповідей:

1. Використання текстових, графічних редакторів та електронних таблиць у юридичній діяльності.

2. Програми роботи з графікою. Порівняльний аналіз.

3. Створення презентацій. Особливості роботи з аудіо-, відеоінформацією.

Перелік ключових термінів та понять теми:

Графічне зображення, комп’ютерна графіка, растрова та векторна графіка, колір малюнка, графічні файли, графічні редактори, графічні інтерфейси, Paint для Windows, завантаження, вікно редактора, редагування малюнку, редагування кольору, програма Microsoft PowerPoint, головне вікно, режими роботи, панелі інструментів, слайди, експортування графічних об’єктів до слайдів, налагодження анімацій, демонстрація презентацій.

Методичні вказівки:

Графічні зображення можуть бути: 1.) растрові (основним елементом, що бере участь в побудові зображення, є точка). Їх легко редагувати, але пам’ять, яку займають графічні файли дуже велика. Для таких зображень відсутня можливість масштабування і при збільшенні їх розмірів губиться якість (зображення неначе "розмивається"), тому застосовується в основному для фотооб’єктів; 2.) векторні (основним елементом є лінія). Пам’ять вони займають компактну, при збільшенні масштабу якість зображення не змінюється, але в такій графіці складно створювати більшість об’єктів, тому використовується для ілюстративних цілей; 3.) фрактальні (основний елемент – формула). Використовується в наукових цілях, де, маючи одиничний об’єкт, який можна описати формулою, створюють з них цілісні структури. Великої пам’яті такі файли не займають.

Графічний редактор Paint входить до складу стандартних програм Windows, найпростіший з редакторів, що призначені для створення і обробки малюнків растрової графіки. Вікно редактора містить ряд типових для вікон середовища Windows елементів (рядок заголовку, рядок меню тощо). Панель інструментів для малювання розміщена ліворуч і включає ряд кнопок, за допомогою яких можна вибрати необхідний інструмент, побудувати типові елементи малюнка, виділити певний фрагмент тощо. Палітра кольорів розміщена внизу і включає 28 зафарбованих різними кольорами квадратів, з яких користувач може вибрати основний колір, яким виконуються побудови, і колір фону. Рядок стану розміщений у нижній частині вікна. Область малювання (обмежена головним меню, панеллю інструментів, палітрою) призначена для побудови малюнка.

Для створення нового малюнка використовується команда "Создать"
з меню "Файл", а для відкриття вже існуючого файла з малюнком використовується команда "Открыть" з меню "Файл". Для збереження малюнка використовуються команди "Сохранить как" або "Сохранить" з меню "Файл".

Для попереднього перегляду малюнка перед його друком треба використати команду "Предварительный просмотр" з меню "Файл", а для друкування малюнка виконати команду "Печать" з меню "Файл".

Для побудови малюнка треба, у першу чергу, вибрати основний колір
і колір фону. Для побудови малюнка користувач може вибрати необхідний інструмент з панелі інструментів, натиснувши відповідну кнопку, наприклад, олівець, пензель, розпилювач, гумку, валик, лінію, криву лінію, прямокутник, округлений прямокутник, еліпс, многокутник, текст, ножиці тощо.

Для редагування малюнка використовують команди меню "Правка", "Вид", "Рисунок". Ряд команд діє тільки на виділений фрагмент малюнка, інші – на весь малюнок. Виділений фрагмент можна очистити, вирізати, скопіювати, перемістити, записати у файл тощо. Команди редагування малюнка дають змогу очистити область малювання, змінити масштаб малюнка, повернути чи нахилити малюнок, змінити його розміри, одержати дзеркальне відображення малюнка тощо. Під редагуванням кольору розуміється зміна кольорів елементів малюнка або палітри. Для зміни будь-якого кольору палітри слід вибрати цей колір, клацнувши по ньому мишею, а потім виконати команду "Изменить палитру" з меню "Параметры".

На сьогоднішній день складова частина пакета Microsoft Office PowerPoint є ведучим програмним забезпеченням для підготовки набору привабливих, професійно оформлених слайдів, що супроводжує виступ. Цей набір і зветься презентацією. Слайди можуть містити: текст, таблиці, діаграми, рисунки, відеокліпи, звуковий супровід, ефекти анімації тощо. Створення їх відбувається з мінімальною витратою зусиль. Спочатку презентація планується, лише потім придумані слайди втілюються в електронну реальність. Залежно від способу презентацій на комп’ютері розрізняють такі їхні види: 1.) із сценарієм (найпоширеніша презентація, де слайди доповнюються засобами показу кольорової графіки й анімації, є можливість під час показу вносити зміни у процес демонстрації, але матеріал озвучує сам ведучий); 2.) інтерактивна (фактично це діалог користувача з комп’ютером, де користувач на екрані здійснює вибір потрібного об’єкта за допомогою "миші" або клавіатури, а на екран порціями виводиться інформація, на яку був запит; порції можна подавати графічно, в текстовому вигляді, за допомогою анімації або відеокліпів, читанням тексту "від автора" і використанням звукових ефектів, із застосуванням усіх елементів у різноманітних поєднаннях); 3.) автоматична (це закінчений інформаційний продукт, який можна перенести на відеоплівку, дискету, компакт-диск і розіслати споживачам; розрізняють торгові, маркетингові, навчальні та корпоративні типи таких презентацій).

Запуск PowerPoint здійснюється за допомогою меню "Пуск", вікноза своєю структурою збігається з вікнами інших засобів, але ліворуч від горизонтальної смуги прокручування є кнопки режимів перегляду слайдів, призначення яких таке:
1.) режим слайдів (для створення і зміни поточного слайда); 2.) режим структури (для ознайомлення із структурою всієї презентації і в разі потреби – її зміни);
3.) режим сортувальника (для перегляду послідовності слайдів у презентації та переходу за допомогою подвійного клацання "миші" до роботи з обраним слайдом – його переміщення, вилучення, добавлення перед ним нових слайдів, завдання інтервалу часу його показу і встановлення анімаційних ефектів переходу від слайда до слайда); 4.) режим сторінок нотаток (для внесення і зміни коментарів до слайда); 5.) режим показу слайдів (для демонстрації презентації).

Для створення презентації можна обрати один із способів:
1.) використовуючи Майстра автозмісту; 2.) на основі шаблону; 3.) самостійно (порожня презентація, де автор має найбільшу свободу). Початок роботи над новою презентацією має такий порядок виконання: "Пуск" → "Пустая презентація" → "Создать слайд" → вибрати потрібний варіант авторозмітки → ввести інформацію в місцезаповнювачі (бажано почати з титульного слайда).

В презентаціях PowerPоint можуть використовуватися об’єкти з інших додатків. Коли всі слайди створено, треба створити підсумковий слайд. Для цього треба:
1.) відкрити готову презентацію (куди буде добавлений підсумковий слайд;
2.) перейти в режим сортувальника;3.) виділити (утримуючи клавішу <Ctrl>) слайди, заголовки яких будуть у підсумковому; 4.) клацнути "мишею" на кнопці "Итоговый слайд" панелі інструментів сортувальника; 5.) "перетягнути" підсумковий слайд у потрібне місце в режимі сортувальника. Анімація окремих елементів слайда, яка пожвавлює сприйняття матеріалу, встановлюється в режимі слайдів, а послідовності – в режимі сортувальника. Після того, як презентацію створено, її треба настроїти для демонстрації (у меню "Показ слайдов" вибрати команду "Настройка презентации", де в рамці "Показ слайдов" вибрати потрібний вид керування переходами (вручну або автоматично). Для запуску презентації з метою демонстрації слайдів застосовуються кілька способів: 1.) запуск презентації у PowerPoint; 2.) запуск презентації з робочого стола; 3.) запуск файла показу слайдів; 4.) запуск довільного показу слайдів.

Завдання до практичного заняття:

До практичного заняття 1:

Завантаживши Pаint для Windows створити свою закінчену композицію на тему, яка вам подобається, використавши при цьому як створення, так і завантаження існуючого малюнку. Використовуючи весь інструментарій програми відредагувати композицію, зберегти у своїй папці (з ім'ям номеру навчальної групи) у файлі з іменем власного прізвища у форматі jpg або bmp.

До практичного заняття 2:

За допомогою програми Microsoft PowerPoint створити нову презентацію з декількох слайдів (не менше 3) з автоматичним послідовним зображенням їх на екрані монітору. Першим слайдом розмістити слайд з заголовком теми, для другого використати малюнок, що зберегли на занятті 1. Зберегти презентацію з іменем "Презентація …. (прізвище)" у своїй папці (з ім'ям номеру навчальної групи).

Склад слайду №1:

1. Міністерство внутрішніх справ України

2. Головне управління МВС України в м. Києві

3. Печерське районне управління ГУ МВС України в м. Києві

4. Слідчий відділ Печерського РУ ГУ МВС України в м. Києві

5. Слідча справа №…

6. Зміст справи

Склад слайду №2

1. Структурна схема слідчої справи :

 
  Тема 5. Комп'ютерна графіка - №1 - открытая онлайн библиотека

Склад слайду №3

Анкетні дані особи :

Ø прізвище, ім’я та по-батькові;

Ø дата народження;

Ø місце народження;

Ø адреса;

Ø місце роботи (або навчання);

Ø посада.

Результати роботи зберегти у файлі з ім’ям “Презентація №… (прізвище)”.

Питання для самоконтролю:

1. Як створити малюнок за допомогою програми Pаint для Windows?

2. Які існують методи експорту малюнків до програми Pаint для Windows?

3. Які інструментальні засоби використовуються у програмі Pаint для Windows для редагування, збереження та друку.

4. Призначення та загальна характеристика графічних редакторів.

5. Типи графічних редакторів.

6. Можливості графічних редакторів.

7. Види графічних зображень.

8. Формати графічних файлів.

9. Структура інтерфейсу користувача текстових редакторів.