Практичне заняття № 2

Тема дисципліни: Microsoft Office. СУБД Access.

Тема заняття: Робота із системою управління базами даних (СУБД) Access.

Мета заняття: Закріпити теоретичні знання студентів і набути практичні відновленню відображення записів, пошуку й заміні даних, копіюванню й видаленню таблиць, сортуванню й фільтрації записів, установки шрифтів і печатки таблиць.

Тривалість: 2 години.

Порядок виконання роботи

1. Увімкніть ПК.

2. Виконайте запуск Access;

3. При необхідності виконайте пошук інформаційної допомоги по тематиці даної роботи;

4. Виконайте активізацію файлу Бази Даних.

5. Відкрийте таблицю, в нашому прикладі Клієнти, у “Режиме таблицы” (Table Datasheet).

6. Access дозволяє сховати існуючі записи в процесі уведення в таблицю нових даних і відновити їх відображення, для чого:

6.1. Для приховання існуючих записів таблиці файлу Бази Даних (БД) при уведенні нових записів у пункті меню “Записи”(Records)виконайтефіксацію на команді “Ввод данных” (Data Entry);

6.2. Для відновлення відображення всіх записів таблиці файлу БДу пункті меню “Записи”(Records)виконайтефіксацію на команді “Удалить фильтр” (Remove Filter).

Примітка: Пункт меню “Записи” доступний тільки в режимі заповнення таблиці.

7. Для додавання записів у таблицю необхідно скористатися одним з наступних способів:

7.1.I спосіб:

7.1.1. У пункті меню “Вставка” (Insert)виконайте фіксацію на команді “Новая запись” (NewRecord).

7.2. II спосіб:

7.2.1. На панелі інструментів виконайте фіксацію на піктограмі “Новая запись” (NewRecord).

8. Додайте в таблицю 5 записів.

9. Для пошуку даних у таблиці необхідно виконати наступну послідовність дій:

9.1. Для відкриття діалогового вікна “Поиск” (Find), необхідно скористатися одним з наступних способів:

9.1.1.I спосіб:

9.1.1.1. У пункті меню “Правка” (Edit)виконайте фіксацію на команді “Найти”(Find).

9.1.2.II спосіб:

9.1.2.1. На панелі інструментів виконаєте фіксацію на піктограмі “Найти” (Find);

9.1.3. III спосіб:

9.1.3.1. Виконайте команду [Ctrl] + [F].

9.2. У діалоговому вікні “Поиск в поле…” (Find), яке відкрилося:

9.2.1. У поле “Образец”(Find What) вказується шуканий об’єкт (уміст поля або його частина), наприклад, потрібно знайти запис із певним прізвищем і для пошуку введіть у це поле відповідне прізвище.

Примітка: Істотно розширити коло пошуку можна, застосувавши символи шаблонів “ * ”і “ ? ”. Зірочка заміняє будь-яку кількість символів, а знак питання – тільки один символ.

9.2.2. У списку, що розкривається, поля“Просмотр” (Search) за замовчуванням установлене значення“Все” (All), тобто пошук ведеться по всіх записах таблиці.

У списку, що розкрився, даного поля можна також установити значення:

Ø “Вниз”(Down) – проглядаються всі дані від поточного запису до кінця таблиці;

Ø “Вверх”(Up) - проглядаються всі дані від поточного запису до початку таблиці.

9.2.3. У списку, що розкривається, поля“Совпадение” (Match) за замовчуванням установлене значення“Поля целиком” (Whole Fields), тобто пошук ведеться при повному збігу один до одного.

У списку, що розкрився, даного поля можна також установити значення:

Ø “С любой частью поля”(Any Part of Field)– уміст поля вважається, що збіглися з об’єктом пошуку, навіть якщо останній становить тільки частину його;

Ø “С начала поля”(Start of Field)– будуть знайдені тільки ті поля, у яких шуканий об’єкт перебуває на самому початку поля.

9.2.4. За замовчуванням у діалоговому вікні пошуку встановлена опція “Только в текущем поле”(Search Only Current Field), тобто пошук здійснюється тільки в активному полі.

Якщо потрібно робити пошук по всій таблиці дана опція відключається;

9.2.5. За замовчуванням у діалоговому вікні пошуку не встановлена опція “С учетом регистра”(Match Case), тобто регістр при пошуку не враховується.

Щоб програма знайшла тільки ті поля, уміст яких відповідає об’єкту пошуку й по способу написання, необхідно дану опцію активізувати;

9.2.6. За замовчуванням у діалоговому вікні пошуку не встановлена опція “С учетом формата полей”(Search Fields As Formatted). Якщо активізувати дану опцію пошук буде істотно вповільнений;

9.2.7. Виконайте фіксацію на кнопці “Найти” (Find First) для включення першого процесу пошуку. Програма починає пошук і при виявленні шуканого об’єкта Access виділяє його.

9.2.8. Виконайте фіксацію на кнопці “Найти далее” (Find Next) для включення наступних процесів пошуку на наявність у них об’єкта пошуку;

9.2.9. Якщо шуканий об’єкт не виявлений, з’являється повідомлення “Поиск записей в приложении 'Microsoft Access' завершен. Образец не найден.”;

9.2.10. Для закриття вікна повідомлення виконайте фіксацію на кнопці “Ok”;

9.2.11. Для завершення процесу пошуку виконайте фіксацію на кнопці “Закрыть” (Close).

10. Для пошуку й заміни даних у таблиці необхідно виконати наступну послідовність дій:

10.1. Для відкриття діалогового вікна “Заменить” (Find), необхідно скористатися одним з наступних способів:

10.1.1.I спосіб:

10.1.1.1. У пункті меню “Правка” (Edit)виконайте фіксацію на команді “Заменить”(Replase).

10.1.2. II спосіб:

10.1.2.1. Виконайте команду [Ctrl] + [H].

10.2. У діалоговому вікні “Замена” (Replase), що відкрилося:

10.2.1. У полі “Образец”(Find What) вказується об’єкт, який необхідно замінити;

10.2.2. У полі “Заменить”(Replace With) уводиться значення, на яке потрібно замінити;

10.2.3. У списку, що розкривається, поля“Просмотр” (Search) за замовчуванням установлене значення“Все” (All), тобто заміна ведеться по всіх записах таблиці.

У списку, що розкрився, даного поля можна також установити значення:

Ø “Вниз”(Down) – заміна даних здійснюється від поточного запису до кінця таблиці;

Ø “Вверх”(Up) - заміна даних здійснюється від поточного запису до початку таблиці.

10.2.4. Виконайте фіксацію на кнопці “Найти далее”(Find Next)для включення процесу. Програма знаходить і маркірує підлягаючій заміні об’єкт, але саму заміну не робить;

10.2.5. Виконайте фіксацію на кнопці “Заменить” (Replace), щоб зробити заміну;

10.2.6. Виконаєте фіксацію на кнопці “Найти далее” (Find Next), щоб продовжити процес без заміни даних у маркірованому об’єкті;

10.2.7. Виконайте фіксацію на кнопці “Заменить все” (Replace All) якщо є абсолютна впевненість у необхідності заміни всіх шуканих об’єктів;

10.2.8. Якщо шуканий об’єкт не виявлений, з’являється повідомлення “Поиск записей в приложении 'Microsoft Access' завершен. Образец не найден.”;

10.2.9. Для закриття вікна повідомлення виконайте фіксацію на кнопці “Ok”;

10.2.10. Для завершення процесу заміни виконайте фіксацію на кнопці “Закрыть”(Close).

11.Для перейменування таблиць необхідно скористатися одним з наступних способів:

11.1. I спосіб.

11.1.1. У вікні бази даних виконайте маркування ім’я таблиці;

11.1.2. Виконайте фіксацію на імені таблиці, при цьому довкола нього з’являється рамка з миготливим курсором усередині;

11.1.3. Уведіть нове ім’я таблиці, наприклад Адреси;

11.1.4. Натисніть клавішу [Enter].

11.2. II спосіб.

11.2.1. У вікні бази даних виконайте маркування ім’я таблиці;

11.2.2. У пункті меню “Правка(Edit)виконайте фіксацію на команді “Переименовать”(Rename);

11.2.3. Уведіть нове ім’я таблиці;

11.2.4. Натисніть клавішу [Enter].

11.3. III спосіб.

11.3.1. У вікні бази даних виконайте маркування ім’я таблиці;

11.3.2. Виконайте фіксацію правої кнопки миші на імені таблиці;

11.3.3. У контекстному меню, що відкрилося, виконайте фіксацію на команді “Переименовать”(Rename);

11.2.4. Уведіть нове ім’я таблиці;

11.2.5. Натисніть клавішу [Enter].

12. Для копіювання структури полів при створенні однотипних таблиць необхідно виконати наступну послідовність дій:

12.1. У вікні бази даних виконайте маркування ім’я таблиці, у нашім прикладі Адреси, і відкрийте її в “Режиме конструктора” (Design View);

12.2. Для розміщення вікон таблиці й Бази Даних на екрані в пункті меню “Окно” (Window) виконайте фіксацію на команді “Слева направо” (Vertically);

12.3. У вікні бази даних на вкладці “Таблица”(Tables) виконайте фіксацію на кнопці “Создать” (New);

12.4. У діалоговому вікні “Новая таблица”(New Table), що відкрилося, для створення таблиці за допомогою конструктора таблиць:

12.4.1. Виконаєте фіксацію на елементі “Конструктор”(Design View);

12.4.2. Виконайте фіксацію на кнопці “Оk”.

12.5. Згорніть вікно Бази Даних.

12.6. Для розміщення вікон таблиці й нової таблиці на екрані в пункті меню “Окно”(Window) виконайте фіксацію на команді “Слева направо”(Vertically);

12.7. Використовуючи технології копіювання (команди пункту меню “Правка” або на панелі інструментів), виконайте копіювання структури довільних полів у нову таблицю.

12.8. Для створеної структури нової таблиці продумайте й оголосіть поле первинного ключа.

12.9. Для збереження структури знову створеної таблиці в пункті меню “Файл”(File) виконайте фіксацію на команді “Сохранить”(Save);

12.10. У діалоговому вікні “Сохранение”(Save), що відкрилося:

12.10.1. У полі “Имя таблицы”(Name Table) уведіть ім’я нової таблиці, наприклад Співробітники;

12.10.2. Виконайте фіксацію на кнопці “Оk”.

13. Для копіювання таблиць у ту ж Базу Даних необхідно виконати наступну послідовність дій:

13.1. Відкрийте вікно бази даних.

13.2. Для відкриття діалогового вікна “Вставка таблицы” (Insert Table) необхідно скористатися одним з наступних способів:

13.2.1. I спосіб.

13.2.1.1. У вікні бази даних виконайте маркування ім’я таблиці, з якої буде створюватися копія, у нашім прикладі Адреси;

13.2.1.2. У пункті меню “Правка”(Edit) виконайте фіксацію на команді “Копировать”(Copy);

13.2.1.3. У пункті меню “Правка”(Edit) виконайте фіксацію на команді “Вставить”(Paste);

13.2.2. II спосіб:

13.2.2.1. У вікні бази даних виконайте маркування ім’я таблиці, з якої буде створюватися копія;

13.2.2.2. На панелі інструментів виконайте фіксацію на піктограмі “Копировать”(Copy);

13.2.2.3. На панелі інструментів виконайте фіксацію на піктограмі “Вставить”(Paste);

13.2.3. III спосіб:

13.2.3.1. У вікні бази даних виконайте маркування ім’я таблиці, з якої буде створюватися копія;

13.2.3.2. Виконайте фіксацію правої кнопки миші на імені або піктограмі таблиці, з якої буде створюватися копія;

13.2.3.3. У контекстному меню, що відкрилося, виконайте фіксацію на команді “Копировать”(Copy);

13.2.3.4. Виконайте фіксацію правої кнопки миші в межах робочого поля вікна Бази Даних;

13.2.3.5. У контекстному меню, що відкрилося, виконайте фіксацію на команді “Вставить” (Paste).

13.2.4. IV спосіб:

13.2.4.1. У вікні бази даних виконайте маркування ім’я таблиці, з якої буде створюватися копія;

13.2.4.2. Виконайте команду [Ctrl] + [C];

13.2.4.3. Виконайте команду [Ctrl] + [V].

13.3. У діалоговому вікні “Вставка таблицы” (Insert Table), що відкрилося:

13.3.1. У полі “Имя таблицы”(Name Table) уведіть ім’я нової таблиці, наприклад Підрозділи;

13.3.2. В області “Параметры вставки”, що містить три опції:

Ø “Только структура” – створюється тільки нова структура таблиці без даних;

Ø “Структура и данные” – створюється повна копія структури таблиці разом з усіма даними;

Ø “Добавление данных в таблицу” – приводить до додавання даних в існуючу таблицю. Ця опція використовується для комбінування таблиць,

- активізуйте другу опцію.

13.3.3. Для завершення копіювання виконайте фіксацію на кнопці “Оk”.

14. Для видалення таблиць необхідно скористатися одним з наступних способів:

14.1. I спосіб.

14.1.1. У вікні бази даних виконайте маркування ім’я таблиці, яку необхідно видалити, наприклад Співробітники;

14.1.2. Натисніть клавішу [Delete];

14.1.3. Для підтвердження видалення в діалоговому вікні, що відкрилося, виконайте фіксацію на кнопці “Да”.

14.2. II спосіб.

14.2.1. У вікні бази даних виконайте маркування ім’я таблиці, яку необхідно видалити;

14.2.2. У пункті меню “Правка”(Edit)виконайте фіксацію на команді “Удалить”(Delete);

14.2.3. Для підтвердження видалення в діалоговому вікні, що відкрилося, виконайте фіксацію на кнопці “Да”.

14.3. III спосіб.

14.3.1. У вікні бази даних виконайте маркування ім’я таблиці, яку необхідно видалити;

14.3.2. Виконайте фіксацію правої кнопки миші на імені або піктограмі таблиці;

14.3.3. У контекстному меню, що відкрилося, виконайте фіксацію на команді “Удалить”(Delete);

14.3.4. Для підтвердження видалення в діалоговому вікні, що відкрилося, виконайте фіксацію на кнопці “Да”.

15. Для зміни порядку записів у таблиці в “Режиме таблицы” (Table Datasheet) необхідно скористатися одним з наступних способів:

15.1.I спосіб:

15.1.1. Установіть курсор у будь-якому місці поля, по якому буде виконуватися сортування записів;

15.1.2. У пункті меню “Записи” (Records)виконайте фіксацію на команді “Сортировка”(Sort);

15.1.3. У підменю, що відкрилося, виконайте фіксацію на відповідній команді:

Ø “Сортировка по возрастанию” (Sort Ascending);

Ø “Сортировка по убыванию” (Sort Descending).

15.2. II спосіб:

15.2.1. Установіть курсор у будь-якому місці поля, по якому буде виконуватися сортування записів;

15.2.2. На панелі інструментів виконайте фіксацію на відповідній піктограмі:

Ø “Сортировка по возрастанию” (Sort Ascending);

Ø “Сортировка по убыванию” (Sort Descending).

16. Для фільтрування записів таблиці по виділеному в “Режиме таблицы” (Table Datasheet) необхідно скористатися одним з наступних способів:

16.1.I спосіб:

16.1.1. Установіть курсор у поле, по якому буде виконуватися фільтрування записів;

16.1.2. У пункті меню “Записи” (Records)виконайте фіксацію на команді “Фильтр”(Filter);

16.1.3. У підменю, що відкрилося, виконайте фіксацію на команді “Фильтр по выделенному”(Filter By Selection).

16.2. II спосіб:

16.2.1. Установіть курсор у поле, за даними якого буде виконуватися фільтрування записів;

16.2.2. На панелі інструментів виконайте фіксацію на піктограмі “Фильтр по выделенному”(Filter By Selection);

Примітка: У нижній частині вікна таблиці з’явиться повідомлення про кількість записів, що задовольняють критеріям фільтра. Букви “ФЛТР” (FLTR) у рядку стану означають, що фільтр активний.

17. Для відключення фільтра в “Режиме таблицы” (Table Datasheet) необхідно скористатися одним з наступних способів:

17.1.I спосіб:

17.1.1. У пункті меню “Записи” (Records)виконайте фіксацію на команді “Удалить фильтр”(Apply Filter).

17.2. II спосіб:

17.2.1. На панелі інструментів виконайте фіксацію на піктограмі “Удалить фильтр” (Apply Filter);

Примітка: З рядка стану, у нижній частині вікна таблиці, зникнуть букви “ФЛТР” (FLTR).

18. Для створення складного И – фильтра (AND – filter) в “Режиме таблицы” (Table Datasheet) необхідно виконати наступну послідовність дій:

18.1. У пункті меню “Записи” (Records)виконайте фіксацію на команді “Фильтр”(Filter) і в підменю, що відкрилося, виконайте фіксацію на команді “Изменить фильтр”(Filter By Form);

або

На панелі інструментів виконайте фіксацію на піктограмі “Изменить фильтр”(Filter By Form);

18.2. При необхідності відмовитися від установок попереднього фільтра на панелі інструментів виконайте фіксацію на піктограмі “Очистить бланк”(Clear Grid);

18.3. Виконайте фіксацію в порожньому осередку під заголовком поля, значення якого буде використано для фільтрування, при цьому в правій частині поля з’являється піктограма списку;

18.4. У списку, що розкривається, виберіть значення поля, по якому буде проведене фільтрування, або введіть ці дані із клавіатури;

18.5. Виконайте аналогічні дії для кожного поля, для якого задається фільтрування;

Примітки: Для правильної роботи фільтра текстові дані, що вводяться із клавіатури, візьміть в лапки.

При завданні критеріїв фільтрування для текстових полів можна використовувати символи шаблонів “ * ”та “ ? ”,адля числових полів – логічні оператори < ; > ; <= ; >= ; = ; < >.

Наприклад, для фільтрування записів з номерами записів більше 10 і із прізвищами начинающимися з букви К уведіть наступні критерії фільтрування:

У поле “Номер запису” - >10;

У поле “Прізвище”“К*”.

18.6. Для відображення відфільтрованих записів необхідно скористатися одним з наступних способів:

18.6.1.I спосіб:

18.6.1.1. У пункті меню “Фильтр” (Filter)виконайте фіксацію на команді “Применить фильтр”(Apply Filter);

18.6.2. II спосіб:

18.6.2.1. На панелі інструментів виконайте фіксацію на піктограмі “Применение фильтра” (Apply Filter);

18.7. Виконайте відключення фільтра.

19. Для створення складного ИЛИ – фильтра (OR – filter) в “Режиме таблицы” (Table Datasheet) необхідно виконати наступну послідовність дій:

19.1. У пункті меню “Записи” (Records)виконайте фіксацію на команді “Фильтр”(Filter) і в підменю, що відкрилося, виконайте фіксацію на команді “Изменить фильтр”(Filter By Form);

або

На панелі інструментів виконайте фіксацію на піктограмі “Изменить фильтр”(Filter By Form);

19.2. Для завдання додаткових умов фільтрування - створення складного ИЛИ – фильтра, наприклад, ще й для фільтрування записів із прізвищами, що починаються з букви П необхідно виконати наступну послідовність дій:

19.2.1. Виконайте фіксацію на ярлику “Или” (Or), розташованому внизу вікна;

19.2.2. Виконайте фіксацію в порожньому осередку під заголовком поля, значення якого буде використано для завдання додаткових умов фільтрування, у нашім прикладі – у поле “Прізвище”;

19.2.3. У поле “Прізвище” уведіть додаткову умову фільтрування – “П*”;

19.3. Виконайте відображення відфільтрованих записів.

19.4. Виконайте відключення фільтра.

20. Самостійно створіть И- фильтры й ИЛИ – фильтрывідповідно до даних Вашої таблиці.

21. Результати покажіть викладачеві для оцінки Вашої роботи.

22. Для установки параметрів шрифту для даних таблиці необхідно виконати наступну послідовність дій:

22.1. У пункті меню “Формат” (Format) виконайте фіксацію на команді “Шрифт” (Font);

22.2. У діалоговому вікні “Шрифт” (Font), що відкрилося, виконайте вибір виду, розміру й накреслення шрифту.

23. Для установки параметрів осередків необхідно виконати наступну послідовність дій:

23.1. У пункті меню “Формат” (Format) виконайте фіксацію на команді “Ячейки” (Cells);

23.2. У діалоговому вікні “Вид сетки” (Cells Effects), що відкрилося:

23.2.1. В області“Оформление(Cell Effect),що містить три опції, вибирається спосіб оформлення осередків:

Ø “Обычное”(Flat) – стандартне оформлення;

Ø “Приподнятое”(Raised) – невиділені осередки таблиці нагадують опуклі кнопки, а маркіровані – натиснуті кнопки;

Ø “Утопленное”(Sunken) – невиділені осередки таблиці нагадують натиснуті кнопки, а маркіровані – опуклі кнопки;

- активізується, як правило,першаопція.

Примітка: При виборі першого способу оформлення осередків - “Обычное”(Flat)з області “Линии сетки” (Gridlines Shown) стають активними опції:

Ø “По горизонтали” (Horizontal);

Ø “По вертикали” (Vertical),

які дозволяють відновлювати відображення розділових ліній у таблиці.

23.2.2. У списку, що розкривається, поля“Цвет линий сетки” (Gridline Color) установлюється колір ліній сітки;

23.2.3. У списку, що розкривається, поля“Цвет фона” (Background Color) установлюється колір фона осередків;

23.2.4. . Виконайте фіксацію на копке “Ok”.

24. Закрийте таблицю.

25. Закрийте файл БД.

26. Вийдіть із Microsoft Access.

27. Виключіть ПК (за вказівкою викладача).

27. Оформіть дану роботу.

Питання та завдання для самоконтролю

1. Як здійснюється одержання інформаційної допомоги по тематиці даної роботи?

2. Методика приховання й відновлення відображення записів.

3. Методика додавання записів у таблицю.

4. Методика пошуку даних у таблиці.

5. Методика пошуку й заміни даних у таблиці.

6. Методика перейменування таблиць.

7. Методика копіювання структури полів при створенні однотипних таблиць.

8. Методика копіювання таблиць у ту ж Базу Даних.

9. Методика видалення таблиць.

10. Методика зміни порядку записів у таблиці.

11. Методика фільтрування записів таблиці й відключення фільтра.

12. Методика створення складного И – фільтра (AND – filter).

13. Методика створення складного АБО – фільтра (OR – filter).

14. Методика відключення фільтра.

15. Методика установки параметрів шрифту.

16. Методика установки параметрів осередків.


Практичне заняття №3

Тема дисципліни: Microsoft Office. СУБД Access.

Тема заняття: Робота з системою управління базами даних (СУБД) Access.

Мета заняття: Закріпити теоретичні знання студентів і набути практичні навички роботи з СУБД Access по створенню в поле списку значень із використанням Майстра підстановок і використанню створеного списку значень, установленню зв’язків між таблицями й використанню встановлених зв’язків між таблицями.

Тривалість: 2 години.

Порядок виконання роботи

1. Увімкніть ПК.

2. Виконайте запуск Access;

3. При необхідності виконайте пошук інформаційної допомоги по тематиці даної роботи;

4. Виконайте активізацію файлу Бази Даних.

5. Представте, що перед Вами поставлена завдання зібрати й систематизувати в створюваній Базі Даних інформацію про асортименти продукції й клієнтах фірми, що торгує автомобілями.

Таким чином, БД буде містити дві таблиці: Клієнти й Пропоновані моделі.

У таблиці Пропоновані моделі будуть зібрані дані про пропоновані моделі автомобілів, їхніх характеристиках, роздрібних цінах.

У таблиці Клієнти будуть використані, в основному, дані таблиці Адреси, створеної на попередніх практичних заняттях.

6. Виконайте копіювання таблиці Адреси файлу БД в цей файл з іменем Клієнти.

7. Внесіть у структуру таблиці Клієнти в файлі БД деякі зміни, щоб вона придбала наступні властивості:

Имя поля Тип данных Размер поля Формат поля Число десятичных знаков Индексированное поле Код модели Числовой Длинное целое Основной Да (Допускаются совпадения)
Имя поля Тип данных Размер поля Формат поля Число десятичных знаков Индексированное поле Номер договора Числовой Длинное целое Основной Да (Совпадения не допускаются)
Имя поля Тип данных Размер поля Значение по умолчанию Условие на значение Сообщение об ошибке   Индексированное поле Обращение Текстовый “Уважаемый!” “Уважаемый!” or “Уважаемая!” Допустимы только значения «Уважаемый!» или «Уважаемая!» Нет
Имя поля Тип данных Размер поля Индексированное поле Фамилия Текстовый Да (Допускаются совпадения)
Имя поля Тип данных Размер поля Индексированное поле Имя Текстовый Нет
Имя поля Тип данных Размер поля Индексированное поле Отчество Текстовый Нет
Имя поля Тип данных Размер поля Индексированное поле Адрес Текстовый Нет
Имя поля Тип данных Размер поля Индексированное поле Почтовый индекс Числовой Длинное целое Нет
Имя поля Тип данных Размер поля Индексированное поле Населенный пункт Текстовый Нет
Имя поля Тип данных Размер поля Индексированное поле Телефон Текстовый Нет
Имя поля Тип данных Формат поля Индексированное поле Дата заказа Дата/Время Краткий формат даты Да (Допускаются совпадения)
Имя поля Тип данных Размер поля Формат поля Число десятичных знаков Индексированное поле Скидка Числовой С плавающей точкой (4 байт) Процентный Нет

Примітка: Спроба зменшити розмір поля в таблиці, що вже містить дані, може привести до втрати або до перекручування даних. Наприклад, розмір текстового поля зменшили з 50-ти символів до 20-ти. Тоді записи, які містять більше 20-ти символів, однаково будуть складатися з 20-ти символів.

7.1. Оголосіть поле Номер договора полем первинного ключа;

Примітки: Поле первинного ключа – унікальне поле, оскільки воно містить однозначний ідентифікатор для кожного запису, тобто:

- Первинний ключ є індексом;

- Він сортує дані по одному або декількох полях

- Не може містити однакові значення для двох різних полів, і не дозволяти уводити в таблицю повторювані дані.

Програма відображає дані в порядку первинного ключа.

7.2. У полі “Обращение” необхідно створити список із двох значень, для чого:

7.2.1. У вікні Конструктора таблиць виконайте фіксацію в колонці “Тип данных” поля “Обращение”, при цьому правій частині осередку з’являється кнопка списку, при фіксації на якій відкривається список з доступними типами даних;

7.2.2.Виконайте фіксацію на необхідному елементі, у нашім прикладі“Мастер подстановок…”(LookupWizard);

7.2.3. У вікні “Создание подстановки” (Lookup Wizard) активізуйте перемикач “Будет введен фиксированный набор значений”(I will type in the values that I want)і виконайте фіксацію на кнопці “Далее”(Next);

7.2.4. У наступному вікні “Создание подстановки”:

7.2.4.1. У полі “Число столбцов” (Number of Columns)залишіть за замовчуванням 1;

7.2.4.2. У полі “Столбец1” уведіть у першому рядку – Уважаемый!, а в другий – Уважаемая!;

7.2.4.3. Виконайте фіксацію на кнопці “Готово”(Finish).

7.3. В області“Свойства поля”(Field Properties) у поле “Значение по умолчанию” (Default Value) уведіть із клавіатури текст, що буде відбиватися в таблиці в поле “Обращение” за замовчуванням при доповненні таблиці записами, у нашім прикладі “Уважаемый!”;

7.4. В області“Свойства поля”(Field Properties) у поле “Условие на значение ” (Validation Rule) необхідно ввести умову на уведення значень, для чого необхідно скористатися одним з наступних способів:

7.4.1. I спосіб:

7.4.1.1. Виконайте фіксацію в області“Свойства поля”(Field Properties)

у полі “Условие на значение” (Validation Rule);

7.4.1.2. Уведіть із клавіатури текст, що буде визначати умови на обмеження даних, що вводяться, у нашім прикладі- Уважаемый! or Уважаемая!.

7.4.2. II спосіб:

7.4.2.1. Виконайте фіксацію в області“Свойства поля”(Field Properties) у полі “Условие на значение” (Validation Rule), при цьому в правій частині поля з’являється піктограма;

7.4.2.2. Виконайте фіксацію на даній піктограмі;

7.4.2.3. У вікні “Построитель выражений”, що відкрилося:

7.4.2.3.1. Уведіть із клавіатури текст - Уважаемый!;

7.4.2.3.2. Виконайте фіксацію на піктограмі “Операторы”;

7.4.2.3.3. Виконайте фіксацію на значенні “Логические”;

7.4.2.3.4. Виконайте фіксацію на логічній умові “OR”;

7.4.2.3.5. Виконайте фіксацію на кнопці “Вставить”;

7.4.2.3.6. Уведіть із клавіатури текст - Уважаемая!;

7.4.2.3.7. Виконайте фіксацію на кнопці “Ok”.

7.5. В області“Свойства поля”(Field Properties) у полі “Сообщение об ошибке” (Validation Text) уведіть з клавіатури текст, що буде відбиватися при вводі в поле “Обращение” відмінних від заданих за умовою значень, наприклад “Допустимы только значения “Уважаемый!” или “Уважаемая!”;

7.6. Відредагуйте структуру таблиці Клієнти в файлі БД, використовуючи вище викладені відомості й практичні навички, придбані на попередніх практичних заняттях;

7.7. Виконайте збереження структури й значень властивостей полів таблиці Клієнти.

8. Створіть структуру нової таблиціПропоновані моделіБази Даних,що буде включати такі поля і їхні властивості:

Имя поля Тип данных Размер поля Формат поля Число десятичных знаков Индексированное поле Код модели Числовой Длинное целое Основной Да (Совпадения не допускаются)
Имя поля Тип данных Размер поля Индексированное поле Модель Текстовый Да (Допускаются совпадения)
Имя поля Тип данных Размер поля Индексированное поле Цвет Текстовый Нет
Имя поля Тип данных Размер поля Формат поля Число десятичных знаков Значение по умолчанию Условие на значение Сообщение об ошибке   Индексированное поле Количество дверей Числовой Байт Основной 2 or 4 Поле может содержать только числа 2 или 4! Нет
Имя поля Тип данных Размер поля Значение по умолчанию Условие на значение Сообщение об ошибке   Индексированное поле Коробка передач Текстовый Ручная «Ручная» or «Автоматика» Допустимы только значения «Ручная» или «Автоматика»! Нет
Имя поля Тип данных Формат поля Число десятичных знаков Индексированное поле Заводская цена Денежный Денежный Авто Нет
Имя поля Тип данных Формат поля Число десятичных знаков Индексированное поле Транспортные издержки Денежный Денежный Авто Нет
Имя поля Тип данных Формат поля Число десятичных знаков Значение по умолчанию Индексированное поле Предпродажная подготовка Денежный Денежный Авто Нет
Имя поля Тип данных Формат Индексированное поле Специальная модель Логический Да/Нет Нет

8.1. Оголосіть поле “Код модели” полем первинного ключа.

8.2. У полі “Количество дверей” необхідно створити список із двох значень 4 or 2.

8.3. У полі “Коробка передач”необхідно створити список із двох значень “Ручная” or “Автоматика”.

8.4. Тому що витрати на передпродажну підготовку для кожної моделі однакові для поля “Предпродажная подготовка”варто вказати яке-небудь фіксоване значення, що буде використовуватися за замовчуванням, наприклад 500. При уведенні даних дане значення автоматично заноситься у відповідне поле кожного запису.

8.5. Виконайте збереження структури й значень властивостей полів таблиці Пропоновані моделі.

9. Для встановлення зв’язку між таблицями у вікні бази даних виконайте наступну послідовність дій:

9.1. У пункті меню “Сервис”(Tools) виконайте фіксацію на команді “Схема данных” (Relationships);

9.2. У діалоговому вікні “Добавление таблицы”(Show Table), що відкрилося:

9.2.1. Виконайте маркування таблиці Пропоновані моделі, яку необхідно зв’язати з таблицею Клієнти;

9.2.2. Виконайте фіксацію на кнопці “Добавить”(Add);

9.2.3. Виконайте маркування таблиці Клієнти;

9.2.4. Виконайте фіксацію на кнопці “Добавить”(Add);

9.2.5. Виконайте фіксацію на кнопці “Закрыть”(Close).

Примітка: Зв’язок між таблицями варто організувати так, щоб при роботі з таблицею Клієнти для одержання необхідної інформації про автомобіль певного типу досить було ввести тільки Код моделі.

9.3. У вікні “Схема данных”(Relationships)за допомогою миші перемістіть використовуване для зв’язку поле Код моделі від однієї таблиці, у нашім прикладі Клієнти, до цього поля іншої таблиці, у нашім прикладі Пропоновані моделі.

9.4. У діалоговому вікні “Связи”(Relationships), що відкрилося:

9.4.1. У полях “Таблица/запрос” (Table/Query) і “Связанная таблица/запрос” (Related Table/Query) відбивається встановлений зв’язок між таблицями;

9.4.2. Для перевірки цілісності зв’язку між обома таблицями активізуйте перемикач “Обеспечение целостности данных” (Enforce Referential Integrity);

9.4.3. У поле “Тип отношения”(Relationship Type) встановлене відношення типу Один-ко-Многим (One-to-many), тобто одному запису головної таблиці Пропоновані моделі може бути поставлене у відповідність кілька записів зв’язаної таблиці Клієнти, адже може бути куплено кілька машин однієї моделі;

9.4.4. Виконайте фіксацію на кнопці “Создать”(Create), і створений зв’язок між таблицями відобразиться графічно.

9.5. Закрийте вікно “Схема данных”.

9.6. Для підтвердження збереження змін у макеті в діалоговому вікні, що відкрилося, виконайте фіксацію на кнопці “Да”.

10. Для редагування даних поля “Код модели” таблиці Клієнти – представимо поле Код модели у вигляді списку, для чого:

10.1. Відкрийте таблицю Клієнти в режимі Конструктора;

10.2. У вікні Конструктора таблиць виконайте фіксацію в колонці “Тип данных” поля “Код модели”, при цьому у правій частині осередку з’являється кнопка списку, при фіксації на якій відкривається список з доступними типами даних;

10.3.Виконайте фіксацію на необхідному елементі, у нашім прикладі,“Мастер подстановок…”(LookupWizard);

10.4. У вікні “Создание подстановки” (Lookup Wizard) активізуйте перемикач “Столбец подстановки использует значения из таблицы или запроса”(I Want the LookupColumn to Look Up the Values in a Table or Query) і виконайте фіксацію на кнопці “Далее”(Next);

10.5. На наступному кроці у вікні “Создание подстановки” з наведеного списку таблиць виконайте маркування таблиці Пропоновані моделі й виконайте фіксацію на кнопці “Далее”(Next);

10.6. На наступному кроці у вікні “Создание подстановки”необхідно виконати наступну послідовність дій:

10.6.1. Із запропонованого списку “Доступных полей”(Available Fields) виберіть поля, значення яких будуть фігурувати в списку, а саме поле “Модель”, і виконайте фіксацію на кнопці “ > ”, при цьому ім’я виділеного поля відіб’ється в області “Выбранные поля”;

Примітка: Ключове поле Код модели автоматично приєднається до списку.

10.6.2. Виконайте фіксацію на кнопці “Далее”(Next);

10.7. На наступному кроці у вікні “Создание подстановки”відключіть опцію “Скрыть ключевую колонку”(Hide Key Column) і виконайте фіксацію на кнопці “Далее”(Next);

10.8. На наступному кроці у вікні “Создание подстановки”із запропонованого списку “Доступных полей”(Available Fields) виберіть поле “Код модели” і виконайте фіксацію на кнопці “Готово”(Finish).

10.9. Виконайте збереження структури та значень властивостей полів таблиці.

11. Відкрийте таблицю Пропоновані моделів “Режиме таблицы” і заповніть наступними даними:

Код моделей Модель Цвет Количество дверей Коробка передач Заводская цена Транспортные издержки Предпродажная подготовка Специальная модель Corolla LiftbackXL Красный торнадо 4 (установлено по умолчанию) Ручная (установлено по умолчанию) Нет
Код моделей Модель Цвет Количество дверей Коробка передач Заводская цена Транспортные издержки Предпродажная подготовка Специальная модель Corolla LiftbackGT Бутылочное стекло Автоматика Нет
Код моделей Модель Цвет Количество дверей Коробка передач Заводская цена Транспортные издержки Предпродажная подготовка Специальная модель Corolla CompactGT Черный Ручная Да
Код моделей Модель Цвет Количество дверей Коробка передач Заводская цена Транспортные издержки Предпродажная подготовка Специальная модель Corolla CompactXL Небесно-голобой Ручная Да
Код моделей Модель Цвет Количество дверей Коробка передач Заводская цена Транспортные издержки Предпродажная подготовка Специальная модель Corolla Kombi Антрацитовый Автоматика Нет

12. Відкрийте таблицю Клієнти в Режиме Таблиці й виконайте уведення 10 довільних записів, використовуючи створені зв’язки.

Примітка: Для заповнення поля “Код моделей” у таблиці Клієнтивикористовуються дані анологічного полятаблиці Пропоновані моделі.

13. Закрийте таблицю.

14. Закрийте файл БД.

15. Вийдіть із Microsoft Access.

16. Виключіть ПК (за вказівкою викладача).

17. Оформіть дану роботу.

Питання та завдання для самоконтролю

1. Як здійснюється одержання інформаційної допомоги по тематиці даної роботи?

2. Методика копіювання таблиці файлу БД у файл інший БД.

3. Методика редагування структури таблиці в режимі Конструктора.

4. Призначення поля первинного ключа.

5. Методика створення в поле списку значень із використанням Майстра підстановок.

6. Методика встановлення зв’язків між таблицями.

7. Методика уведення даних у таблицю з використанням створеного списку значень.

8. Методика уведення даних з використанням установлених зв’язків між таблицями.


Практичне заняття №4

Тема дисципліни: Microsoft Office. СУБД Access.

Тема заняття: Робота з системою управління базами даних (СУБД) Access.

Мета заняття: Закріпити теоретичні знання студентів і набути практичні навички роботи з СУБД Access по створенню запитів і автоформ.

Тривалість: 2 години.

Порядок виконання роботи

1. Увімкніть ПК.

2. Виконайте запуск Access;

3. При необхідності виконайте пошук інформаційної допомоги по тематиці даної роботи.

4. Відкрийте файл Бази Даних створений на попередніх заняттях.

5. Для створення запиту необхідно відкрити діалогове вікно “Новый запрос”(New Query), для чого можна скористатися одним з наступних способів:

5.1. I спосіб:

5.1.1. У пункті меню “Вид” (View) виконайте фіксацію на команді “Объекты Базы данных”(Database Objects);

5.1.2. У підменю, що відкрилося виконайте фіксацію на команді “Запросы”(Queries);

5.1.3. У вікні Бази Даних виконайте фіксацію на кнопці “Создать”(New).

5.2. II спосіб:

5.2.1. Виконайте фіксацію на вкладці “Запросы”(Queries);

5.2.2. Виконайте фіксацію на кнопці “Создать” (New).

5.3. У діалоговому вікні “Новый запрос”(New Query), що відкрилося, пропонуються наступні способи створення запиту:

Ø “Конструктор”(Design View)-створення запиту без допомоги майстра;

Ø “Простой запрос”(Simple Query Wizard) -створення простого запиту на основі обраних полів;

Ø “Перекрестный запрос”(Crosstab Query Wizard) - створення запиту, дані в якому мають компактний формат, подібний до формату подання даних в електронних таблицях;

Ø “Повторяющиеся записи”(Find Duplicates Query Wizard) - створення запиту, що вибирає повторювані записи з таблиці або простого запиту;

Ø “Записи без подчиненных”(Find Unmatched Query Wizard)-створення запиту, що вибирає з таблиці запису, не пов’язані із записами з іншої таблиці.

5.3.1. Для створення запитів виконайте маркування відповідного способу створення;

5.3.2. Виконайте фіксацію на кнопці “Ok”.

6. Для створення запиту за допомогою конструктора запитів необхідно виконати наступну послідовність дій:

6.1. У діалоговому вікні “Новый запрос”(New Query) виконайте маркування способу створення “Конструктор” (Design View) і виконайте фіксацію на кнопці “Ok”;

6.2. У результаті відкривається порожнє вікно конструктора запиту й діалогове вікно “Добавление таблиц”(Show Table).

6.3. У діалоговому вікні “Добавление таблиц”(Show Table), що відкрилося, здійснюється вибір таблиць і запитів, які будуть використовані при розробці запиту й воно містить три вкладки:

Ø “Таблицы” (Tables);

Ø “Запросы” (Queries);

Ø “Таблицы и Запросы” (Both).

6.3.1. Перейдіть на вкладку “Таблицы”(Tables), виконавши фіксацію на відповідному ярлику;

6.3.2. Виконайте маркування таблиці Пропоновані моделі;

6.3.3. Виконайте фіксацію на кнопці “Добавить”(Add);

6.3.4. Виконайте маркування таблиці Клієнти;

6.3.5. Виконайте фіксацію на кнопці “Добавить”(Add);

6.3.6. Закрийте діалогове вікно, виконавши фіксацію на кнопці “Закрыть”(Close), при цьому імена обраних таблиць відобразяться у вікні проектування запиту.

Примітка: За допомогою команди “Добавить таблицы”(Show Table) з меню “Запрос”(Query) можна знову відкрити діалогове вікно “Добавить таблицы” (Show Table)і поповнити список таблиць запиту.

6.4. Вікно Конструктора запиту розділено на дві частини. У верхній половині перебувають вікна таблиць зі списками полів. Ім’я кожної таблиці відображається в рядку заголовка такого вікна.

При складанні запиту на основі декількох таблиць між ними необхідно встановити зв’язок, задавши відношення між полями. У противному випадку результат обробки запиту може виявитися некоректним.

У даному прикладі відношення між двома таблицями вже задано, між полями обох таблиць проведена лінія. Крім того, на схемі видний характер зв’язку - “Один ко многим”. Головної в цьому випадку є таблиця Пропоновані моделі (з її боку зв’язок позначений символом 1).

У нижній половині вікна Конструктора запиту розташовується бланк запиту.

Розробка запиту виконується в кілька етапів:

1. Додавання полів у запит.

2. Установка критеріїв відбору записів.

3. Сортування записів.

6.5. Для додавання полів у запит необхідно скористатися одним з наступних способів:

Примітка: Щоб у рядку “Имя таблицы”(Table)бланка запиту відображалося ім’я таблиці, у пункті меню “Вид”(View) варто встановити опцію “Имена таблиц”(Table Names).

6.5.1. I спосіб:

6.5.1.1.Додати потрібні поля в бланк запиту можна методом Drag and Drop “перетаскування” їхніх імен зі списку, що перебуває у верхній частині вікна конструктора, у рядок “Поле”(Field) бланка запиту, наприклад, поміствть в рядок “Поле”(Field) поле Код модели таблиці Пропоновані моделі.

6.5.2. II спосіб:

6.5.2.1. Додати потрібні поля в бланк запиту можна шляхом подвійної фіксації на імені поля, наприклад, помістіть в другу колонку рядка “Поле”(Field) поле Призвище таблиці Клієнти.

6.5.3. III спосіб:

6.5.3.1. Додати потрібні поля в бланк запиту можна, виконавши фіксацію на кнопці списку, розташованої в рядку “Поле”(Field)праворуч і вибрати ім’я поля зі списку запропонованих полів, наприклад, помістіть в третю колонку поле Ім’ятаблиці Клієнти.

6.5.4. Додати кілька полів з таблиці можна шляхом маркування імен перерахованих полів у списку таблиці, утримуючи натиснутою клавішу [Ctrl] і “перетягнувши” маркіровані поля в порожню колонку рядка “Поле”(Field).

Як тільки ви відпустите кнопку миші, імена полів будуть розподілені по колонках.

6.6. Використовуючи даний спосіб, додайте наступні поля таблиці Клієнти.

- По батькові;

- Адреса;

- Поштовий індекс;

- Населений пункт;

- Телефон;

- Дата замовлення.

6.7. Для видалення полів із запиту необхідно скористатися одним з наступних способів:

6.7.1. I спосіб:

6.7.1.1. Виконайте маркування колонки де перебуває поле, яке видаляється, наприклад, поле Прізвище;

6.7.1.2. Натисніть клавішу [Del].

6.7.2. II спосіб:

6.7.2.1. Виконайте маркування колонки де перебуває поле, яке видаляється, наприклад, поле Адреса;

6.7.2.2. У пункті меню “Правка”(Edit) виконайте фіксацію на команді “Удалить столбцы”(Delete Columns).

6.7.3. Використовуючи дані способи, видалите із бланка запиту всі поля.

6.8. Для включення в запит всіх полів таблиці необхідно скористатися одним з наступних способів:

6.8.1. I спосіб:

6.8.1.1. Виконайте подвійну фіксацію в рядку заголовка таблиці, наприклад Клієнти, у верхній частині вікна конструктора запиту, і “перетягніть” їх у рядок “Поле” бланка запиту. Access автоматично розмістить кожне поле таблиці в окремій колонці.

6.8.2. II спосіб:

6.8.2.1. Виконайте маркування символу “ * ” у списку полів таблиці, наприклад Пропоновані моделі, у верхній частині вікна конструктора запиту, і “перетягніть” його в бланк запиту або виконайте подвійну фіксацію. У результаті всі поля таблиці будуть включені в запит, але в бланку з’явиться тільки запис Ім'я Таблиці *, у даному прикладі Пропоновані моделі *.

Примітка: Обидва способи дають однаковий результат. Однак другий спосіб має наступну перевагу: коли у вихідній таблиці додаються або видаляються поля, автоматично змінюється й запит.

6.9. Для видалення таблиць із запиту необхідно скористатися одним з наступних способів:

6.9.1. I спосіб:

6.9.1.1. Виконайте маркування будь-якого з її полів у верхній частині вікна конструктора запиту, наприклад, будь-яке поле таблиці Пропоновані моделі;

6.8.1.2. Натисніть клавішу [Del].

6.9.2. II спосіб:

6.9.2.1. Виконайте маркування будь-якого з її полів у верхній частині вікна конструктора запиту, наприклад будь-яке поле таблиці Клієнти;

6.9.2.2. У пункті меню “Правка”(Edit) виконайте фіксацію на команді “Удалить”(Delete).

Примітка: Поля вилученої із запиту таблиці, які були поміщені в бланк запиту, віддаляються автоматично.

6.10. Використовуючи отримані практичні навички, здійсніть вибір таблиць Пропоновані моделі й Клієнти для запитів і додайте в бланк запиту наступні поля таблиці Пропоновані моделі:

- Код моделі;

- Модель;

- Заводська ціна;

- Транспортні витрати;

- Передпродажна підготовка;

інаступні поля таблиці Клієнти:

- Прізвище;

- Населений пункт;

- Телефон;

- Дата замовлення.

7. Припустимо, необхідно створити запит на вибірку даних з таблиць Пропоновані моделі й Клієнти й установити клієнтів, наприклад у Дніпропетровську, що замовили автомобілі.

7.1. За допомогою критеріїв відбору користувач указує Access, які записи потрібно вибирати в таблицях і відображати в таблиці результатів виконання запиту. Критерії відбору вказуються для одного або декількох полів.

Формований у даному прикладі запит повинен відбирати дані про клієнтів із Дніпропетровська, що замовили автомобілі, тому для поля Населений пункт встановіть в рядку “Условие отбора ”(Criteria) критерій відбору:

- Населений пункт -Дніпропетровськ.

7.2. Для рішення даного завдання необхідно виконати наступну послідовність дій:

7.2.1. В осередок, на перетинанні рядка “Условие отбора”(Criteria) і стовпця Населений пункт, уведіть Дніпропетровськ.

7.2.2. Після уведення вираження натисніть клавішу [Enter], внаслідок чого Access перевірить його синтаксис і укладе це значення в лапки;

7.3. Для збереження запиту необхідно виконати наступну послідовність дій:

7.3.1. I способ:

7.3.1.1. У пункті меню “Файл”(File) виконайте фіксацію на команді “Сохранить”(Save).

7.3.2. II спосіб:

7.3.2.1. На панелі інструментів “Дезайнера запроса”(Query Design) виконайте фіксацію на піктограмі “Сохранить”(Save).

7.4. У діалоговому вікні “Сохранение”, що відкрилося:

7.4.1. У полі “Имя запроса” (Query Name) уведіть ім’я запиту, що зберігається, наприклад, Дніпропетровськ;

7.4.2. Виконайте фіксацію на кнопці “Ok”.

7.5. Для відображення результату запиту необхідно скористатися одним з наступних способів:

7.5.1. I спосіб:

7.5.1.1. У пункті меню “Запрос”(Query) виконайте фіксацію на команді “Запуск”(Run).

7.5.2. II спосіб:

7.5.2.1. На панелі інструментів “Дезайнера запроса”(Query Design) виконаєте фіксацію на піктограмі “Запуск”(Run).

7.5.3. III спосіб:

7.5.3.1. На панелі інструментів “Дезайнера запроса”(Query Design) у списку “Вид” (View), що розкривається,виконайте фіксацію на пункті“Режим таблицы” (Datasheet View).

7.5.4. IV спосіб:

7.5.4.1. У пункті меню “Вид”(View) виконайте фіксацію на команді “Режим таблицы”(Datasheet View).

7.5.5. V спосіб:

7.5.5.1. У вікні Бази Даних на вкладці “Запросы”(Queries) виконайте маркування необхідного імені запиту, у нашім прикладі, Дніпропетровськ і виконайте фіксацію на кнопці “Открыть” (Open) або виконайте подвійну фіксацію на піктограмі імені запиту.

7.6. Access відобразить на екрані набір записів, які відібрані відповідно до заданого критерію.

7.7. Для закриття вікна “Запрос на выборку”, виконайте фіксацію на кнопці “Закрыть окно”.

8. Допустимо, необхідно відредагувати створений запит на вибірку даних з таблиць Пропоновані моделі й Клієнти.

Формований запит повинен відбирати дані про клієнтів із Дніпропетровська, що замовили, наприклад, в 2006 році автомобілі:

- - Corolla Kombi (12410) і

- - Corolla LiftbackXL (12579).

Крім того, записи запиту необхідно відсортувати по зростанню по датах замовлення. Тому, для перерахованих нижче полів, установіть в рядку “Условие отбора” (Criteria) додаткові критерії відбору:

- Код моделі12410;

- Дата замовлення - > 01.01.2007 and <31.12.2007;

Для поля Код моделі встановіть рядку “Или” (Or) критерій відбору – 12579.

8.1. Для редагування створеного запиту необхідно виконати наступну послідовність дій:

8.1.1. У вікні Бази Даних перейдіть на вкладку “Запросы”(Queries);

8.1.2. Виконайте маркування необхідного імені запиту, у нашім прикладі, Дніпропетровськ;

8.1.3. Виконайте фіксацію на кнопці “Конструктор” (Design) або виконайте подвійну фіксацію на піктограмі імені запиту.

8.2. В осередок, на перетинанні рядка “Условие отбора”(Criteria) і стовпця Код моделі, уведіть критерій для поля Код моделі - 12410. Після уведення вираження натисніть клавішу [Enter], внаслідок чого Access перевірить його синтаксис і нормалізує запис відповідно до правил запису критеріїв;

8.3. В осередок, на перетинанні рядка “Или”(Or)і стовпця Код моделі, уведіть критерій для поля Код моделі - 12579. Після уведення вираження натисніть клавішу [Enter], внаслідок чого Access перевірить його синтаксис і нормалізує запис відповідно до правил запису критеріїв;

8.4. В осередок, на перетинанні рядка “Или”(Or)і стовпця Населений пункт, уведіть критерій для поля Населений пункт- Дніпропетровськ. Після уведення вираження натисніть клавішу [Enter], внаслідок чого Access перевірить його синтаксис і нормалізує запис відповідно до правил запису критеріїв;

8.5. Уведіть критерій для поля Дата замовлення >01.01.2006 and <31.12.2006. Після уведення вираження натисніть клавішу [Enter], внаслідок чого Access автоматично перетворить дату у формат, обраний у режимі конструктора таблиці. (Short Date: 01.01.2006), і вставить перед нею й після її знак #.

8.6. Для виконання сортування записів у запиті необхідно виконати наступну послідовність дій:

8.6.1. Виконайте фіксацію на перетинанні рядка “Сортировка” і стовпця бланка запиту, що містить ім’я поля, по якому необхідно зробити сортування, у даному прикладі - Дата замовлення;

8.6.2. Виконайте фіксацію на кнопці списку, що розкривається, у рядку“Сортировка” (Sort);

8.6.3. У списку, що розкрився, виконайте фіксацію на обраному способі сортування, у нашім прикладі“ по возрастанию”.

Примітка: Записи в запиті можуть бути відсортовані за алфавітом, по зростанню (Ascending) або по убуванню (Descending). Можна також одночасно робити сортування по вмісту декількох полів (до десяти).

8.7. Виконайте збереження змін у запиті.

8.8. Виконайте запуск відредагованого запиту.

Примітки: Якщо буде потреба можна скасувати відображення поля в результуючому наборі записів (навіть того, по якому виробляється сортування).

Поле відображається в таблиці результатів запиту, якщо у відповідній колонці бланказапиту, у рядку“Вывод на экран”(Show)включений контрольний індикатор.

9. Запит можна використовувати для виконання розрахунків і підведення підсумків, узагальнивши дані з вихідних таблиць. Для цих цілей в Access передбачені статистичні функції SQL. Статистичну функцію задають у рядку “Групповая операция”(Total).

9.1. Для відображення в бланку запита рядка “Групповая операция” (Total) необхідно скористатися одним з наступних способів:

9.1.1. I спосіб:

9.1.1.1. У пункті меню “Вид”(View) виконайте фіксацію на команді “Групповые операции”(Total).

9.1.2. II спосіб:

9.1.2.1. На панелі інструментів “Дезайнера запроса”(Query Design) виконайте фіксацію на піктограмі “Групповые операции”(Total).

9.2. За допомогою статистичної функції можна обробити вміст кожного поля запиту. Результат обробки з’являється в результуючому наборі записів запиту.

9.3. За допомогою статистичної функції можна виконувати наступні обчислення в запиті.

Функція Дія
Sum Підсумовування значень певного поля, що перебувають у записах, які відібрані запитом
Avg Обчислення середнього значення в тих записах певного поля, які відібрані запитом
Min Обчислення мінімального значення в записах певного поля, відібраних запитом
Мах Обчислення максимального значення в записах певного поля, відібраних запитом
Count Обчислення кількості записів, відібраних запитом, у певному полі
First Визначається перше значення в зазначеному полі записів, відібраних запитом
Last Визначається останнє значення в зазначеному полі записів, відібраних запитом
StDev Обчислюється стандартне відхилення значень даного поля для всіх записів, відібраних запитом
Var Обчислюється варі