Практичні заняття №7,8

Тема дисципліни: Microsoft Office. СУБД Access.

Тема заняття: Робота з системою управління базами даних (СУБД) Access.

Мета заняття: Закрипіти теоретичні знання студентів і набути практичні навички роботи з СУБД Access по проектуванню та створенню звітів і наклейок за допомогою Майстра звітів

Тривалість: 4 години.

Порядок виконання роботи

1. Увімкніть ПК.

2. Виконайте запуск Access.

3. При необхідності виконайте пошук інформаційної допомоги по тематиці даної роботи.

4. Виконайте активізацію Вашого файлу Бази Даних.

5. Завдання: За допомогою Майстра звітів необхідно на базі таблиці Клієнти створити звіт, згрупувавши дані по кодом моделей, що дозволяє з’ясувати попит на автомобілі моделі Corolla Liftback GT і дату надходження замовлення від певного клієнта.

6. Для створення звіту необхідно у вікні Базы Данных відкрити діалогове вікно “Новый отчет” (New Report), для чого можна скористатися одним з наступних способів.

6.1. I спосіб.

6.1.1. У пункті меню “Вид” (View) виконайте фіксацію на команді “Объекты Базы данных” (Database Objects);

6.1.2. У підменю, що відкрилося, виконайте фіксацію на команді “Отчеты” (Report);

6.1.3. У вікні Бази Даних виконайте фіксацію на кнопці “Создать” (New).

6.2.. II спосіб.

7.2.1. Виконайте фіксацію на вкладці “Отчеты” (Report);

7.2.2. Виконайте фіксацію на кнопці “Создать” (New).

7.3. У діалоговому вікні “Новый отчет” (New Report), що відкрилося, пропонуються наступні способи створення Звіту:

Ø Конструктор (Design View) – самостійне створення нового звіту;

Ø Мастер отчетов (Report Wizard) - автоматичне створення звіту на основі обраних полів;

Ø Автоотчет (AutoReport) - на основі обраної таблиці автоматично створює звіт одного з наступних типів:

· в столбец у (columnar);

· ленточная (tabular).

Ø Мастер диаграмм (Chart Wizard) – створення звіту з діаграмою;

Ø Почтовые наклейки (Label Wizard) - створення звіту, відформатованого для печатки поштових наклейок.

8. Для створення звіту за допомогою Майстра звітів (Report Wizard) необхідно виконати наступну послідовність дій.

8.1. У діалоговому вікні “Новый отчет” (New Report), використовуючи один із запропонованих способів, виконайте наступні дії.

8.1.1. I способ.

8.1.1.1. У списку, що розкривається, поля“Выберите в качестве источника данных таблицу или запрос:” виконайте вибір таблиці (запиту), що буде основою для складання звіту, у нашім прикладі, Клієнти;

Примітка: Вибір таблиці або запиту на цьому етапі можна не виконувати.

8.1.1.2. Промаркируйте спосіб створення - “Мастер отчетов” (Report Wizard)”;

8.1.1.3. Виконайте фіксацію на кнопці “Оk”.

8.1.2. II спосіб.

8.1.2.1. У списку, що розкривається, поля“Выберите в качестве источника данных таблицу или запрос:” виконайте вибір таблиці (запиту), що буде основою для складання звіту, у нашім прикладі, Клієнти;

Примітка: Вибір таблиці або запиту на цьому етапі можна не виконувати.

8.1.2.2. Виконайте подвійну фіксацію в рядку обраного способу створення форми, у нашім прикладі, “Мастер отчетов” (Report Wizard)”.

8.2. Відкривається діалогове вікно “Создание отчетов”, у якому за кілька кроків Майстер звітів допоможе нам створити необхідний звіт.

8.2.1. На першому кроці вибираються поля таблиць, що включаються у звіт;

8.2.1.1. У списку, що розкривається, поля “Таблицы/Запросы:” (Tables/Queries) виконайте вибір таблиці (запиту), що буде основою для складання звіту, у нашім прикладі, Клієнти;

Примітка: Якщо вибір таблиці або запиту був виконаний на попередньому етапі, цей пункт ігнорується.

8.2.1.2. Зі списку “Доступные поля” (Available Fields) перенесіть у список “Выбранные поля” (Selected Fields) поля, які передбачається використовувати у звіті. Додайте в проект звіту назви наведених нижче полів у наступній послідовності:

Ø Код моделі;

Ø Прізвище;

Ø Дата замовлення.

Примітка:Перемістіть поля в тій послідовності, у якій вони повинні бути представлені у звіті.

8.2.1.3. Після того як всі необхідні поля виявляться в правому списку й будуть розташовані в зазначеній послідовності, виконайте фіксацію на кнопці “Далее” (Next).

8.2.2. На другому кроці додаються рівні угруповання звіту.

8.2.2.1. Нам необхідно згрупувати дані по кодах моделей (ім’я поля, за даними якого передбачається виконати угруповання, повинне відображатися у верхньому прямокутнику в правій частині вікна), що при актуалізації звіту дозволить відразу визначити, яке кількість автомобілів кожної моделі замовлено на цей момент;

8.2.2.2. Для вибору способу групування виконайте фіксацію на кнопці “Группировка” (Grouping Options).

8.2.2.3. У діалоговому вікні “Интервалы группировки”(Grouping Intervals), що відкрилося, виконуються зміни інтервалів групування даних у звіті:

8.2.2.3.1. У списку, що розкривається, поля “Интервалы группировки” (Grouping intervals) виберіть “Обычный” (Normal);

Примітка: При використанні стандартного значення “Обычный” (Normal) в одну групу поєднуються записи з однаковими значеннями в заданому полі.

8.2.2.3.2. У поле “Поля группировки” (Group level fields) відображається ім’я поля, що обране для угруповання даних у звіті, у нашім прикладі Код моделі;

8.2.2.3.3. Не змінюючи установки, виконайте фіксацію на кнопці “Ok”;

8.2.2.4. Виконайте фіксацію на кнопці “Далее” (Next).

8.2.3. На третьому кроці встановлюється порядок сортування записів.

8.2.3.1. В області “Допускается сортировка записей в возрастающем или убывающем порядке, включающая до 4 полей” (You can sort records by up to four fields in other ascending or descending order), у списку, що розкривається, поля“1”(списку першого рівня сортування) виберіть додаткове сортування по полюПризвище;

8.2.3.2. Установіть порядок сортування по зростанню за допомогою кнопки, розташованої праворуч від поля.

Примітки: Автоматично відбувається сортування даних по тим полям, по яких виконується угруповання (у нашім прикладі по полю Код Моделі).

Якщо запису в групі повинні бути розсортовані й по інших полях, їх необхідно вказати в чотирьох спеціально відведених для цього полях: 1,2,3,4 в області “Допускается сортировка записей в возрастающем или убывающем порядке, включающая до 4 полей”.

8.2.3.3. Виконайте фіксацію на кнопці “Далее” (Next).

8.2.4. На четвертому кроці вибирається вид макета для звіту (як дані повинні бути представлені у звіті).

8.2.4.1. В області “Макет” (Layout) пропонуються наступні варіанти відображення даних:

Ø Ступенчатый (Stepped) - східчасте розташування даних різних рівнів;

Ø Блок (Block) -блокове розташування даних;

Ø Структура 1 и Структура 2 (Outline left 1 і Outline left 2) -східчасте розташування рівнів з перекриттям;

Ø По левому краю 1 и По левому краю 2 (Align Left 1 і Align Left 2)- вирівнювання даних всіх рівнів по лівому краї.

Виконайте включення перемикача обраного виду відображення даних, наприклад, “Ступенчатый”(Stepped);

8.2.4.2. У лівій частині вікна пропонується переглянути макет розташування даних звіту при обраному способі розташування даних.

8.2.4.3. В області“Ориентация”(Orientation) пропонується вибрати необхідну орієнтацію даних звіту на аркуші:

Ø Книжная (portrait);

Ø Альбомная (landscape).

Виконаєте активізацію перемикача обраного варіанта, наприклад Книжная.

8.2.4.4. Щоб повніше використовувати площу сторінки, виконайте включення вимикача “Настроить ширину полей для размещения на одной странице”(Adjust the field width so all fields fit on page), за допомогою якого задається підбор оптимальної ширини полів;

8.2.4.5. Виконайте фіксацію на кнопці “Далее” (Next).

8.2.5. На п’ятому кроці вибирається необхідний стиль звіту.

8.2.5.1. Виконайте маркування обраного варіанта стилю, наприклад “Формальний” (Formal);

8.2.5.2. Виконайте фіксацію на кнопці “Далее” (Next).

8.2.6. На шостому кроці задається ім’я нового звіту.

8.2.6.1. У поле“Задайте имя отчета:” (What title do you want for your report?) за замовчуванням уведене ім’я таблиці, на основі якої створюється звіт;

Залишіть ім’я, пропоноване програмою, або введіть нове, наприклад, Огляд замовлень;

8.2.6.2. В області “Дальнейшие действия:” необхідно активізувати один із двох перемикачів:

Ø “ Просмотр отчета” (Preview the report);

Ø “ Изменение структуры отчета” (Modify the report’s design).

Для того щоб оцінити зовнішній вигляд звіту, тобто відобразити звіт у режимі попереднього перегляду даних активізуйте перший перемикач, а для редагування макета звіту у вікні конструктора - другий перемикач;

8.2.6.3. Виконайте включення першого перемикача - “Просмотр отчета” (Preview the report);

8.2.6.4. Виконайте фіксацію на кнопці “Готово” (Finish).

8.3. Тому що в області “Дальнейшие действия:” включений перемикач “Просмотр отчета” (Preview the report), створений звіт відіб’ється в режимі попереднього перегляду.

Примітки: Як тільки на екрані відобразиться створений звіт, задайте для його вікна полноэкранное подання, щоб можна було побачити найбільшу частину сторінки звіту.

У готовому звіті в області нижнього колонтитула автоматично встановлюється дата його створення. Сам же звіт має вигляд таблиці: імена полів наведені під рядком заголовка й відділені від неї й від даних жирною лінією. Групи рядків, що починаються кодом деякої моделі, містять списки клієнтів, які замовили дану модель. Там же наведені дати замовлень.

9. Для збереження звіту в пункті меню “Файл” (File) виконайте фіксацію на команді “Сохранить” (Save) або скористайтеся клавіатурною командою [CTRL] + [S].

10. Створений звіт може бути представлений в одному з наступних режимів:

Ø Предварительный просмотр (Preview the report);

Ø Конструктор(Design).

11. Для переходу з одного режиму відображення звіту в іншій можна скористатися одним з наступних способів:

11.1. I спосіб.

11.1.1. У процесі створення звіту за допомогою Майстра звітів перейти в режим Конструктора можна, включивши на останньому кроці майстра перемикач “Изменение структуры отчета” (Modify the report’s design).

11.2. II спосіб.

11.2.1. У пункті меню “Вид” (View) виконайте фіксацію на команді “Конструктор” (Design).

11.3. III спосіб.

11.3.1. Виконайте фіксацію на кнопці “Вид” (View) на панелі інструментів.

11.4. IV спосіб.

11.4.1. Виконайте фіксацію на кнопці “Закрыть” (Close) на панелі інструментів.

11.5. V спосіб.

11.5.1. У вікні бази даних на вкладці “Отчеты” (Report) виконайте маркування імені необхідного звіту;

11.5.2. Виконайте фіксацію на кнопці “Конструктор” (Design).

12. Для додаткових настроювань і редагування створеного звіту виконайте перемикання відображення звіту в режимі Конструктор.

12.1. Перш ніж приступитися до редагування звіту, уважно ознайомтеся з його структурою. Будь-який звіт містить кілька областей, що дозволяє автоматизувати процес його оформлення. Функції кожної області найбільше яскраво проявляються в багатосторінкових звітах. Нижче наведений короткий огляд областей звітів.

Заголовок отчета(Report Header)

Заголовок звіту розташований на першій сторінці звіту перед верхнім колонтитулом. В області заголовка нашого звіту перебуває текст Огляд замовлень. У багатосторінковому звіті розділ заголовка відображається тільки на першій сторінці.

Верхний колонтитул (Page Header)

Верхній колонтитул за замовчуванням міститься на кожній сторінці звіту. Його появу можна заблокувати на сторінках, що містять шапку або резюме. Звичайно верхній колонтитул містить заголовки стовпчиків (у нашім звіті: - імена полів Код моделі, Прізвище й Дата замовлення).

Заголовок группы (Group Header)

Заголовок групи складається з іменія групи й слова Заголовок группы. У нашім звіті цей заголовок має такий вид: Заголовок группы «Код моделі».

Область данных(Detail)

Елементи цієї області повторюються для кожного обраного з таблиці запису. В області даних нашого звіту перебувають значення з полів Прізвище й Дата замовлення.

Примечание группы (Group Footer)

Примітка групи з’являється наприкінці групи записів. Воно застосовується головним чином для вказівки числа записів або суми значень у полях групи. У нашім звіті примітка групи відсутня. Заголовок даної області включає ім’я групи й слово Примечание, наприклад Код Моделі Примечание.

Нижний колонтитул(Page Footer)

Нижній колонтитул присутній на кожній сторінці звіту. Найчастіше його використовують для відображення номерів сторінок. За замовчуванням майстер звітів уводить у нижній колонтитул функцію =Страница(Page). Якщо звіт містить багато записів і займає кілька сторінок, вони автоматично нумеруються. Крім того, майстер звітів уводить у нижній колонтитул вираження =Now(), що під час генерації звіту заміняється поточною датою.

Примечание отчета(Report Footer)

Примітка вставляється наприкінці звіту й може містити резюме до всього звіту. Це остання область проекту звіту, але при печатці вона розміщається попередє нижнього колонтитулу останньої сторінки.

12.2. За замовчуванням всі області звіту мають однакову ширину й при зміні ширини однієї області, автоматично змінюється ширина всього звіту.

Примітка:Установити необхідний розмір області можна, задавши відповідні значення, для властивостей Высота (Height) і Ширина (Width) у вікні Свойства (Properties).

12.3. Розібравшись із призначенням всіх областей звіту, спробуйте поліпшити зовнішній вигляд свого звіту й розташувати вихідні дані під відповідними заголовками.

12.4. При редагуванні звіту використовуйте навички, отримані при виконанні попередньої практичної роботи №№5-6 (п.п. 18-26).

12.5. Закрийте Ваш звіт, виконавши фіксацію на кнопці “Закрыть окно”(Close) у вікні звіту або в пункті меню “Файл” (File) виконайте фіксацію на команді “Закрыть” (Close).

12.6. На запит “Сохранить изменения макета или структуры отчета «Имя отчета»?” виконайте фіксацію на кнопці “Да”.

13. Завдання: За допомогою Майстра звітів необхідно створити звіт про вартість замовлених автомобілів за заводською ціною й за відпускними цінами з обчисленням проміжних підсумків по кодам моделей і загального підсумку.

Для створення звіту будуть використані дані полів:

Код моделі, Прізвище (з таблиці Клієнти);

Заводська ціна (з таблиці Пропоновані моделі).

14. Для створення звіту відкрийте діалогове вікно “Новый отчет” (New Report).

15. Для створення звіту за допомогою Майстра звітів (Report Wizard) необхідно виконати наступну послідовність дій.

15.1. У діалоговому вікні “Новый отчет” (New Report), що відкрилося, виконайте наступні дії.

15.1.1. У списку, що розкривається, поля “Выберите в качестве источника данных таблицу или запрос:” виконайте вибір таблиці, що буде основою для складання звіту, у нашім прикладі, Клієнти;

Примітка: Вибір таблиці на цьому етапі можна не виконувати.

15.1.2. Промаркируйте спосіб створення - “Мастер отчетов” (Report Wizard)”;

15.1.2. Виконайте фіксацію на кнопці “Оk”.

Примітка: Замість пунктів 15.1.2. і 15.1.3. можна виконати подвійну фіксацію на обраному способі створення звіту, у нашім прикладі, “Мастер отчетов” (Report Wizard).

15.2. Відкривається діалогове вікно “Создание отчетов”, у якому за кілька кроків Майстер звітів допоможе нам створити необхідний звіт.

Примітка: Тому що в створюваному звіті, буде присутнє числове поле, Майстер звітів буде працювати трохи інакше, чим при створенні попереднього звіту.

15.2.1. На першому кроці вибираються поля таблиць, що включаються у звіт.

15.2.1.1. У списку, що розкривається, поля “Таблицы/Запросы:” (Tables/Queries) виконайте вибір таблиці (запиту), що буде основою для складання звіту, у нашім прикладі, Клієнти;

Примітка: Якщо вибір таблиці або запиту був виконаний на попередньому етапі, цей пункт ігнорується.

15.2.1.2. Зі списку “Доступные поля” (Available Fields) перенесіть у список “Выбранные поля” (Selected Fields) поля, які передбачається використовувати у звіті.

Додайте в проект звіту назви наведених нижче полів у такій послідовності:

Ø Код моделі;

Ø Прізвище.

15.2.1.3. У списку, що розкривається, поля “Таблицы/Запросы:” (Tables/Queries) виконайте вибір другої таблиці, поля який будуть також використані для створення звіту, у нашім прикладі, Пропоновані моделі;

Примітка: Допускається вибір полів з декількох таблиць або запитів.

15.2.1.4. Зі списку “Доступные поля” (Available Fields) перенесіть у список “Выбранные поля” (Selected Fields) поля, які передбачається використовувати у звіті.

Додайте в проект звіту, у даному прикладі, назву поля:

Ø Заводська ціна.

15.2.1.5. Після того як всі зазначені поля виявляться в правому списку й будуть розташовані в необхідній послідовності, виконайте фіксацію на кнопці “Далее” (Next).

15.2.2. На другому кроці вибирається тип подання даних.

15.2.2.1. У лівій області виконайте маркування пункту “по Клієнти” тобто ім’я таблиці, по полю якої передбачається групувати дані у звіті;

15.2.2.2. Виконайте фіксацію на кнопці “Далее” (Next).

15.2.3. На третьому кроці додаються рівні угруповання звіту.

15.2.3.1. У лівій області виконайте подвійну фіксацію на імені поля Код моделі.

Тому що в поставленому завданні нам пропонується згрупувати дані по кодам моделей (ім’я поля, за даними якої передбачається виконати угруповання, повинне відображатися у верхньому прямокутнику в правій частині вікна), що при актуалізації звіту дозволить відразу визначити, яку кількість автомобілів кожної моделі замовлено на цей момент.

15.2.3.2. Для вибору способу групування виконайте фіксацію на кнопці “Группировка” (Grouping Options);

15.2.3.3. У діалоговому вікні “Интервалы группировки”(Grouping Intervals), що відкрилося, виконуються зміни інтервалів групування даних у звіті.

15.2.3.3.1. У списку, що розкривається, поля“Интервалы группировки” (Grouping intervals) виберіть“Обычный” (Normal).

Примітки: При використанні стандартного значення “Обычный” (Normal) в одну групу поєднуються записи з однаковими значеннями в заданому полі.

Для числових полів можна задати угруповання по десятках, сотням і іншим значенням.

Для текстових полів можна задати угруповання по уведеній першій букві або декільком першим буквам і т.і.

15.2.3.3.2. У полі “Поля группировки” (Group level fields) відображається ім’я поля, що обране для угруповання даних у звіті, у нашім прикладі Код моделі.

15.2.3.3.3. Не змінюючи установки, виконайте фіксацію на кнопці “Ok”.

15.2.3.4. Виконайте фіксацію на кнопці “Далее” (Next).

15.2.4. На четвертому кроці вибирається порядок сортування й обчислення, які необхідно виконати для записів.

15.2.4.1. Для вибору полів і дії з даними виконайте фіксацію на кнопці “ Итоги”;

15.2.4.2. У вікні “Итоги”, що відкрилося, виконайте вибір полів і дії з даними.

15.2.4.2.1. В області, “Какие итоговые значения необходимо вычислить?” відображаються імена полів, які містять числові дані й вимикачі наступних обчислень:

Ø Sum – підсумовування даних;

Ø Avg - обчислення середнього значення;

Ø Min – знаходження мінімального значення;

Ø Max – знаходження максимального значення.

Виконайте включення вимикача Sum для числового поляЗаводська ціна.

15.2.4.2.2. В області “Показать” пропонується два перемикачі:

Ø Данные и итоги;

Ø Только итоги.

Виконайте активізацію перемикача “Данные и итоги”, що дозволить відображати у звіті записи з даними, а також проміжні й загальні підсумки.

15.2.4.2.3. Виконайте фіксацію на кнопці “Ok”.

15.2.4.3. В області “Допускается сортировка записей в возрастающем или убывающем порядке, включающая до 4 полей” (You can sort records by up to four fields in other ascending or descending order), у списку, що розкривається, поля“1”(списку першого рівня сортування) виберіть додаткове сортування по полюПризвіще;

15.2.4.4. Установіть порядок сортування по зростанню за допомогою кнопки, розташованої праворуч від поля;

15.2.4.5. Виконайте фіксацію на кнопці “Далее” (Next).

15.2.5. На п’ятому кроці вибирається вид макета для звіту (як дані повинні бути представлені у звіті).

15.2.5.1. В області “Макет” (Layout) виконайте включення перемикача обраного виду відображення даних, наприклад, “Ступенчатый”(Stepped);

15.2.5.2. У лівій частині вікна пропонується переглянути макет розташування даних звіту при обраному способі розташування даних;

15.2.5.3. В області“Ориентация”(Orientation) пропонується вибрати необхідну орієнтацію даних звіту на аркуші.

Виконайте включення перемикача обраного варіанта, наприклад Книжная.

15.2.5.4. Щоб повніше використовувати площу сторінки, виконайте включення вимикача “Настроить ширину полей для размещения на одной странице”(Adjust the field width so all fields fit on page), за допомогою якого задається підбор оптимальної ширини полів;

15.2.5.5. Виконайте фіксацію на кнопці “Далее” (Next).

15.2.6. На шостому кроці вибирається необхідний стиль звіту.

15.2.6.1. Виконайте маркування обраного варіанта стилю, наприклад “Формальный” (Formal);

15.2.6.2. Виконайте фіксацію на кнопці “Далее” (Next).

15.2.7. На сьомому кроці задається ім’я нового звіту.

15.2.7.1. У поле “Задайте имя отчета:” (What title do you want for your report?) за замовчуванням уведене ім’я таблиці, на основі якої створюється звіт.

Залишіть ім’я, пропоноване програмою, або введіть нове, наприклад, Вартість замовлень.

15.2.7.2. В області “Дальнейшие действия:” необхідно активізувати один із двох перемикачів:

Ø Просмотр отчета (Preview the report);

Ø Изменение структуры отчета (Modify the report’s design).

Для того щоб оцінити зовнішній вигляд звіту, тобто відобразити звіт у режимі попереднього перегляду даних активізуйте перший перемикач, а для редагування макета звіту у вікні конструктора - другий перемикач;

15.2.7.3. Виконайте включення першого перемикача “Просмотр отчета” (Preview the report);

15.2.7.4. Виконайте фіксацію на кнопці “Готово” (Finish).

15.3. Тому що в області “Дальнейшие действия:” включений перемикач “Просмотр отчета” (Preview the report), створений звіт відіб’ється в режимі попереднього перегляду.

16. Виконайте збереження звіту.

17. Виконайте перемикання відображення звіту в режим Конструктора й розташуйте вихідні дані й результати компактно й чітко по відповідних стовпчиках.

18. Тому що, відпускна ціна автомобіля відрізняється від заводський, її обчислення здійснимо, використовуючи можливості Access.

18.1. Для зміни напису для поля Заводська ціна необхідно виконати наступну послідовність дій.

18.1.1. Виконайте подвійну фіксацію в області Верхний колонтитул на поле найменування Заводська ціна;

18.1.2. У вікні властивостей, що відкрилося, на вкладці “Макет” (Format) для властивості Подпись (Caption) уведіть нове значення Ціна без нарахувань;

18.1.3. Закрийте вікно властивостей, залишивши інші установки без змін.

18.2. Для вставки заголовка нового поля Відпускна ціна, необхідно виконати наступну послідовність дій.

18.2.1. На панелі “Панель элементов”(Object) виконайте фіксацію на кнопці Надпись (Label);

18.2.2. Перемістіть покажчик миші, що змінився, в областьВерхний колонтитул у місце розміщення заголовка поля праворуч від написуЦіна без нарахувань і виконайте фіксацію;

18.2.3. Уведіть у нього вираження Відпускна ціна, внаслідок чого програма встановить необхідний для розміщення цього напису розмір;

18.2.4. Перегляньте звіт, що редагується, у режимі попереднього перегляду.

18.3. Для вставки поля, що обчислюється, та уміст якого визначається шляхом множення значення поля Заводська ціна, для якого у вікні властивостей установлений тип Денежный (Currency), на число 1,2 (число 1,2 служить для обчислення відпускної ціни при величині податку на додану вартість 20%) необхідно виконати наступну послідовність дій.

Примітка: У полі Відпускна ціна обчислюються ціни на моделі машин з урахуванням ПДВ.

18.3.1. На панелі “Панель элементов”(Object) виконайте фіксацію на кнопці Поле (Text Box);

18.3.2. Помістіть це поле в Область данных праворуч від поля Заводська ціна, при цьому:

лівий елемент – тип елемента Подпись, буде містити номер поля,

правий - тип елемента Поле,буде містити посилання Свободный (Unbound);

18.3.3. Для уведення в правий елемент поля Полеформули обчислення необхідно виконати наступну послідовність дій.

18.3.3.1. Виконайте маркування правого елемента поля;

18.3.3.2. Виконайте виклик вікна властивостей, правого елемента поля;

18.3.3.3. На вкладці “Данные” (Data) для властивості Данные (Control Source) уведіть з клавіатури формулу в наступному форматі: =[Заводська ціна]*1,2;

Примітка: Щоб не займатися уведенням формули із клавіатури, можна скористатися Построителем выражений(Expression Builder), для виклику якого необхідно виконати фіксацію на кнопці построителя, розташованої праворуч від рядка Данные;

18.3.3.4. На вкладці “Макет” (Format) для властивості Формат поля (Format) установіть Денежный (Currency);

18.3.3.5. На вкладці “Макет” (Format) для властивості Число десятичных знаков (Decimal Places) установіть Авто (Auto);

18.3.3.6. Закрийте вікно властивостей, залишивши інші установки без змін;

18.4. Перегляньте звіт, що редагується, у режимі попереднього перегляду.

18.5. Для видалення лівого елемента – Подпись.

18.5.1. У режимі конструктор виконайте маркування лівого елемента поля;

18.5.2. Натисніть клавішу [Delete].

18.6. Перегляньте звіт, що редагується, у режимі попереднього перегляду.

18.7. Для вставки поля, що обчислюється, і уміст якого визначає проміжну суму відпускних цін по відповідній моделі машин, необхідно виконати наступну послідовність дій.

18.7.1. На панелі “Панель элементов”(Object) виконайте фіксацію на кнопці Поле (Text Box).

18.7.2. Помістіть це поле в область Примечание группы, при цьому:

лівий елемент – тип елемента Подпись, буде містити номер поля;

правий - тип елемента Поле,буде містити посилання Свободный (Unbound).

18.7.3. Для уведення в правий елемента поля Поле формули обчислення необхідно виконати наступну послідовність дій.

18.7.3.1. Виконайте маркування правого елемента поля;

18.7.3.2. Виконайте виклик вікна властивостей правого елемента поля;

18.7.3.3. На вкладці “Данные” (Data) для властивості Данные (Control Source) уведіть c клавіатури формулу в наступному форматі: =Sum([Заводська ціна]*1,2);

Примітка: Щоб не займатися уведенням формули з клавіатури, можна скористатися Построителем выражений(Expression Builder).

18.7.3.4. На вкладці “Макет” (Format) для властивості Формат поля (Format) установыть Денежный (Currency);

18.7.3.5. На вкладці “Макет” (Format) для властивості Число десятичных знаков (Decimal Places) установыть Авто (Auto);

18.7.3.6. Закрийте вікно властивостей, залишивши інші установки без змін.

18.8. Виконайте видалення лівого елемента – Подпись.

18.9. Перегляньте звіт, що редагується, у режимі попереднього перегляду.

18.10. Вставку поля, що обчислюється, в область Примечание отчета, уміст якого визначає загальну суму відпускних цін по всіх моделях машин, виконайте самостійно.

Примітка:Формула для обчислення загальної суми аналогічна попередньої.

18.11. Перегляньте звіт, що редагується, у режимі попереднього перегляду.

19. Для поліпшення зовнішнього вигляду створеного звіту, допустимо, ми вирішили створити й впровадити в область Заголовок отчета фірмовий знак, поточну дату перемістити з області Нижний колонтитул в область Заголовок отчета, а в область Нижний колонтитул увести назву фірми, необхідно виконати наступну послідовність дій.

19.1. Для створення фірмового знака в програмі Paint необхідно виконати наступну послідовність дій.

19.1.1. Виконайте запуск програми Paint;

19.1.2. Створіть фірмовий знак Tojota, що складається з окружності із двома вписаними в неї еліпсами, що утворять літеру Т.

 
  Практичні заняття №7,8 - №1 - открытая онлайн библиотека

Примітка:Переконайтеся, що окружність кругла, а більші півосі еліпсів розташовані перпендикулярно.

19.2. Для збереження створеного файлу в пункті меню “Файл” (File) виконайте фіксацію на команді “Сохранить Как” (Save As).

Примітка: Збережіть створений малюнок у папці Мои документы, у папці з шифром групи під ім’ям: Ваше прізвище.bmp.

19.3. Для впровадження фірмового знака необхідно виконати наступну послідовність дій.

19.3.1. За допомогою інструмента “Выделение” (Select) виконайте виділення створеного малюнка;

19.3.2. У пункті меню “Правка” (Edit) виконайте фіксацію на команді “Копировать” (Copy);

19.3.3. Активізуйте вікно Access;

19.3.4. Виконайте фіксацію в області Заголовок отчета.

19.3.5. У пункті меню “Правка” (Edit) виконайте фіксацію на команді “Специальная вставка” (Paste Special) і в діалоговому вікні “Специальная вставка”, що відкрилося, виконайте фіксацію на кнопці “Ok”;

19.3.6. Відредагуйте розміри й місце розташування фірмового знака;

19.3.7. Перегляньте звіт, що редагується, у режимі попереднього перегляду.

19.4. Для переміщення поточної дати з області Нижний колонтитул в область Заголовок отчета, в області Нижний колонтитул виконайте маркування елемента поля з вираженням =Now() і перемістіть його в область Заголовок отчета.

19.5. Для уведення назви фірми в область Нижний колонтитул, щоб він відображався на кожній сторінці звіту, необхідно виконати наступну послідовність дій.

19.5.1. На панелі “Панель элементов”(Object) виконайте фіксацію на кнопці Надпись (Label);

19.5.2. Перемістіть покажчик миші, що змінився, в областьНижний колонтитул у місце розміщення заголовка поля ліворуч від функції для печатки номерів сторінок і виконайте фіксацію;

19.5.3. Уведіть у нього вираження Представництво Tojota в Україні.

Примітки: Тому що напис розміщений в області Нижний колонтитул, ця назва буде присутня наприкінці кожної сторінки.

Якщо напис помістити в області Примечание отчета, то вона з’явиться тільки один раз наприкінці звіту.

19.5.4. Перегляньте звіт, що редагується, у режимі попереднього перегляду.

20. Для редагування номерів сторінок необхідно виконати наступну послідовність дій.

20.1. Сторінки звіту можна пронумерувати, додавши в заголовки або в колонтитули текстове поле, у якому будуть відображатися номера сторінок;

20.2. Зміст правого елемента даного поля визначається у вікні властивостей, на вкладці “Данные” (Data) для властивості Данные (Control Source).

Примітка: Деякі параметри відображення номерів сторінок представлені в таблиці.

Вираження Результат
=[Page] 1,2,3
=“Стор.”&[Page] Стор. 1, Стор. 2, Стор. 3
=[Page]&“/3стор.” 1/3 стор., 2/3 стор., 3/3 стор.
=[Page]&“з 3стор. ” 1 из 3 стор., 2 из 3 стор., 3 из 3 стор.
=“Стор.”&[Page]“з 3” Стор. 1 з 3, Стор. 2 з 3, Стор. 3 з 3
=Format(Page“000”) 001, 002, 003

20.3. Виконайте експерименти з параметрами відображення номерів сторінок у звіті, переглядаючи звіт, що редагується, у режимі перегляду.

21. Попередній перегляд звітів.

21.1. У режимі попереднього перегляду можна побачити, як буде виглядати звіт у надрукованому виді. Існує два режими попереднього перегляду звітів.

21.1.1. Перегляд зразка макета звіту.

Даний режим доступний тільки з режиму конструктора. Він використовується для перевірки макета звіту. У ньому відображається тільки частина даних, необхідних для заповнення кожного з елементів звіту.

Для активізації цього режиму в пункті меню “Вид” (Edit) виконайте фіксацію на команді “Образец” (Layout Preview).

21.1.2. Перегляд повного вмісту звіту.

Для активізації цього режиму в пункті меню “Вид” (Edit) виконайте фіксацію на команді “Предварительный просмотр” (Print Preview) або виконайте фіксацію на кнопці “Предварительный просмотр”на панелі інструментів.

22. Печатка звіту.

Звіт можна вивести на печатку, як з вікна бази даних, так і з режиму Конструктора або попереднього перегляду.

Примітка: При печатці Access ураховує установки, виконані в діалоговому вікні “Параметры страницы” (Page Setup) з меню “Файл” (File).

22.1. Для запуску звіту на печатку в пункті меню “Файл” (File) виконайте фіксацію на команді “Печать” (Print);

22.2. У діалоговому вікні “Печать” (Print), що відкрилося, виконайте установку необхідних параметрів печатки і виконайте фіксацію на кнопці “Ok”- для включення процесу печатки, у даному прикладі виконайте фіксацію на кнопці “Отмена”.

23. Закрийте створений звіт, виконавши фіксацію на кнопці “Закрыть окно” і в запиті “Сохранить изменения макета или структуры отчета “…”?” підтвердіть свій намір.

24. Використовуючи отримані навички, за допомогою Майстра звітів самостійно створіть:

Ø Звіт про замовлені моделі, згрупувавши дані по Кодам моделей.

Для створення звіту використовуйте дані полів:

Код моделі, Прізвище, Населений пункт(з таблиці Клієнти);

Модель, Колір, Кількість дверей (з таблиці Пропоновані моделі).

У створюваному звіті виконайте додаткове сортування по полю Населений пункт.

Ø Звіт про повну вартість замовлених автомобілів з урахуванням ПДВ (20%), згрупувавши дані по Кодам моделей.

Для створення звіту використовуйте дані полів:

Код моделі, Прізвище, Номер договору(з таблиці Клієнти);

Заводська ціна, Транспортні витрати й Передпродажна підготовка (з таблиці Пропоновані моделі).

У створюваний звіт додайте поле, що обчислюється - Відпускна ціна, і виконайте додаткове сортування по полю Прізвище.

25. Самостійно створіть за допомогою “ Автоотчет в столбец” (AutoReport columnar) звіт на підставі даних з таблиці Клієнти.

Примітки: Створення “Автоотчет в столбец” і “Автоотчет ленточный” відбувається за один крок: після вибору у вікні “Новый отчет” (New Report) таблиці, на підставі якої буде створені звіт і фіксації на кнопці “Оk”. Access автоматично формує звіт, у якому будуть абсолютно всі поля з даній таблиці, але в іншій формі подання даних, чим коли звіт створюється за допомогою Майстра звітів.

Крім того, звіти можна створювати не тільки на підставі полів таблиці, а також і на підставі наявних запитів.

26. Самостійно створіть за допомогою “Автоотчет ленточный” (AutoReport tabular) звіт на підставі даних з таблиці Пропоновані моделі.

27. Створені звіти представте викладачеві для оцінки Вашої роботи.

28. Завдання: За допомогою Майстра по створенню поштових наклейок необхідно створити стандартну поштову наклейку.

29. Для створення поштової наклейки необхідно у вікні Бази Даних відкрити діалогове вікно “Новый отчет” (New Report).

29.1. У діалоговому вікні “Новый отчет” (New Report), що відкрилося, виконаєте наступні дії;

29.2. У списку, що розкривається, поля“Выберите в качестве источника данных таблицу или запрос:” виконайте вибір таблиці, що буде основою для створення поштової наклейки, у нашім прикладі, Клієнти;

29.3. Виконайте маркування способу створення - “Почтовые наклейки” (Label Wizard)”;

29.4. Виконайте фіксацію на кнопці “Оk”.

30. Відкривається діалогове вікно “Создание почтовых наклеек”, у якому за кілька кроків майстер по створенню поштових наклейок допоможе нам створити необхідну поштову наклейку.

30.1. На першому кроці програма пропонує вибрати один зі стандартних форматів наклейок або вказати свій формат.

30.1.1. Для відображення списку стандартних форматів наклейок вимикач “Наклейки других размеров” (Show custom label sizes) повинен бути відключений.

30.1.2. В області “Система единиц” (Unit of Measure) пропонується задати необхідну одиницю виміру:

Ø Британская (English);

Ø Метрическая (Metric).

Виконайте активізацію перемикача обраного варіанта, наприклад Метрическая.

30.1.3. В області “Тип наклеек” (Label Type) пропонується задати необхідний вид паперу, використовуваний для печатки наклейок:

Ø На листах (Sheet feed);

Ø Рулонные (Continuous).

Виконайте активізацію перемикача обраного варіанта, наприклад На листах.

30.1.4. У списку поля “Выберите размер наклейки”(What label size would you like?) пропонуються розміри для створення стандартні наклейок і їхнє число по горизонталі.

Виконайте маркування необхідного розміру наклейки;

30.1.5. Виконайте фіксацію на кнопці “ Далее Далі” (Next).

30.2. На другому кроці нам пропонується задати параметри шрифту: - вид, розмір, накреслення й колір.

30.2.1. В області “Атрибуты текста” (Text appearance) залишіть параметри пропоновані програмою або у відповідних полях списків, що розкриваються, установіть свої;

30.2.2. У лівій частині вікна пропонується переглянути задані параметри;

30.2.3. Виконайте фіксацію на кнопці “Далее” (Next).

30.3. На третьому кроці нам пропонується вибрати імена полів, їхня послідовність і розташування.

30.3.1. Зі списку “Доступные поля” (Available Fields) перенесіть у список “Прототип наклейки” (Prototype Label) поля, які передбачається використовувати в наклейці.

Примітки: Два поля в одному рядку розділяються не тільки пробілами, але й іншими символами, наприклад кома.

У поле списку “Прототип наклейки” перехід до нового рядка виконується за допомогою клавіші [Enter].

Поряд з перерахованими изменяющимися даними полів наклейка може містити й незмінну частину, наприклад такі написи як Замовлене або Особисто/Секретно.

Додайте в поле списку “Прототип наклейки” назви наведених нижче полів у такій послідовності:

Ø Поштовий індекс;

Ø Населений пункт;

Ø Адреса;

Ø Прізвище.

30.3.2. Виконайте фіксацію на кнопці “Далее” (Next).

30.4. На четвертому кроці визначається порядок сортування наклейок.

30.4.1. Зі списку поля “Доступные поля” (Available Fields) перенесіть у список поля “Сортировка” (Sort by) ім’я поля, по якому передбачається виконати сортування наклейок на аркуші, наприклад Населений пункт;

30.4.2. Виконайте фіксацію на кнопці “Далее” (Next).

30.5. На п’ятому кроці задається ім’я для створюваних наклейок.

30.5.1. У поле“Введите имя отчета:” (What title do you want for your report?) за замовчуванням уведене вираження Наклейки й ім’я таблиці, на основі якої створюється поштова наклейка

Залишіть ім’я пропоноване програмою або введіть нове, наприклад, Наклейки для замовлень;

30.5.2. В області “Дальнейшие действия:” необхідно активізувати один із двох перемикачів:

Ø Просмотр наклеек в том виде, в котором они будут напечатаны;

Ø Изменение макета наклеек.

Для того щоб оцінити зовнішній вигляд поштових наклейок, тобто відобразити наклейки в режимі попереднього перегляду активізуйте перший перемикач, а для редагування макета поштових наклейок у вікні конструктора - другий перемикач.

Виконайте включення першого перемикача “Просмотр наклеек в том виде, в котором они будут напечатаны” (Preview);

30.5.3. Виконайте фіксацію на кнопці “Готово” (Finish).

30.6. Тому що в області “Дальнейшие действия:” включений перемикач “Просмотр наклеек в том виде, в котором они будут напечатаны” (Preview), створені поштові наклейки відіб’ються в режимі попереднього перегляду.

31. Виконайте збереження поштових наклейок.

32. Закрийте створені поштові наклейки.

33. Завдання: За допомогою Майстра по створенню поштових наклейок необхідно створити нестандартну поштову наклейку.

34. Для створення поштової наклейки у вікні Бази Даних відкрийте діалогове вікно “Новый отчет” (New Report).

35. У діалоговому вікні “Новый отчет” (New Report), що відкрилося, виконайте наступні дії.

35.1. У списку, що розкривається, поля“Выберите в качестве источника данных таблицу или запрос:” виконайте вибір таблиці, що буде основою для створення поштової наклейки, у нашім прикладі, Клієнти;

35.2. Виконайте маркування способу створення - “Почтовые наклейки” (Label Wizard)”;

35.3. Виконайте фіксацію на кнопці “Оk”.

36. Відкривається діалогове вікно “Создание почтовых наклеек”, у якому за кілька кроків майстер по створенню поштових наклейок допоможе нам створити необхідну поштову наклейку.

36.1. На першому кроці програма пропонує вибрати один зі стандартних форматів наклейок або вказати свій формат.

36.1.1. Для відображення списку нестандартних форматів наклейок вимикач “Наклейки других размеров” (Show custom label sizes) повинен бути включений;

36.1.2. Для створення нестандартних наклейок виконайте фіксацію на кнопці “Настройка”(Customize);

36.1.3. У діалоговому вікні “Размеры наклеек” (New Label Size), що відкрилося, виконайте фіксацію на кнопці “Создать” (New);

36.1.4. У вікні, що відкрилося, схематично показане розташування наклейок на аркуші паперу;

36.1.4.1. Уведіть у відповідні поля значення розмірів:

· для відступів від країв сторінки задайте значення 1 см.;

· для висоти наклейки - 4 см.;

· для ширини наклейки - 5 см.;

· для відступів тексту від країв наклейки усередині наклейки - 0,5 см.;

· відстань між наклейками - 1 см.

36.1.4.2. У поле “Число по горизонтали” уведіть значення 3;

36.1.4.3. В області “Система единиц” (Unit of Measure) пропонується задати необхідну одиницю виміру:

Ø Британская (English);

Ø Метрическая (Metric).

Виконайте активізацію перемикача обраного варіанта, наприклад Метрическая.

36.1.4.4. В області “Тип наклеек” (Label Type) пропонується задати необхідний вид паперу, використовуваний для печатки наклейок:

Ø На листах (Sheet feed);

Ø Рулонные (Continuous).

Виконаєте активізацію перемикача обраного варіанта, наприклад На листах.

36.1.4.5. В області“Ориентация”(Orientation) пропонується вибрати необхідну орієнтацію поштових наклейок на аркуші:

Ø Книжная (portrait);

Ø Альбомная (landscape).

Виконайте активізацію перемикача обраного варіанта, наприклад Альбомная.

36.1.4.6. У поле “Название” (Label Name) залишіть ім’я пропоноване програмою або введіть нове, наприклад, Наклейки замовлень.

36.1.4.7. Виконайте фіксацію на кнопці “Оk”.

36.1.5. У вікні “Размеры наклеек” (New Label Size), ім’я створеної наклейки й інформація про її параметри, заноситься в список нестандартних наклейок;

36.1.6. Виконайте фіксацію на кнопці “Закрыть”(Close);

36.1.7. Виконайте фіксацію на кнопці “Далее” (Next).

36.2. На другому кроці пропонується задати параметри шрифту: - вид, розмір, накреслення й колір.

36.2.1. В області “Атрибуты текста” (Text appearance) залишіть параметри пропоновані програмою або у відповідних полях списків, що розкриваються, установіть свої;

36.2.2. У лівій частині вікна пропонується переглянути задані параметри;

36.2.3. Виконайте фіксацію на кнопці “Далее” (Next).

36.3. На третьому кроці пропонується вибрати імена полів, їх послідовність і розташування.

36.3.1. Зі списку “Доступные поля” (Available Fields) перенесіть у список “Прототип наклейки” (Prototype Label) поля, які передбачається використовувати в наклейці;

36.3.2.Додайте в поле списку “Прототип наклейки” назви наведених нижче полів у такій послідовності:

Ø Поштовий індекс, Населений пункт;

Ø Адреса;

Ø Прізвище.

36.3.2. Виконайте фіксацію на кнопці “Далее” (Next).

36.4. На четвертому кроці визначається порядок сортування наклейок.

36.4.1. Зі списку поля “Доступные поля” (Available Fields) перенесіть у список поля “Сортировка” (Sort by) ім’я поля, по якому передбачається виконати сортування наклейок на аркуші, наприклад Прізвище;

36.4.2. Виконайте фіксацію на кнопці “Далее” (Next).

36.5. На п’ятому кроці задається ім’я для створюваних наклейок.

36.5.1. У поле“Введите имя отчета:” (What title do you want for your report?) за замовчуванням уведене вираження Наклейки й ім’я таблиці, на основі якої створюється поштова наклейка;

Залишіть ім’я пропоноване програмою або введіть нове.

36.5.2. В області “Дальнейшие действия:” необхідно активізувати один із двох перемикачів:

Ø Просмотр наклеек в том виде, в котором они будут напечатаны;

Ø Изменение макета наклеек.

Для того щоб оцінити зовнішній вигляд поштових наклейок, тобто відобразити наклейки в режимі попереднього перегляду активізуйте перший перемикач, а для редагування макета поштових наклейок у вікні конструктора - другий перемикач.

Виконайте включення першого перемикача “Просмотр наклеек в том виде, в котором они будут напечатаны” (Preview);

36.5.3. Виконайте фіксацію на кнопці “Готово” (Finish).

Примітка: Недолік наклейки полягає в тому, що прізвища адресата зазначені в називному відмінку. Для усунення цього недоліку рекомендується ввести в базу даного поля для зберігання прізвищ у давальному відмінку. Звичайно, заповнення таблиці при цьому ускладниться.

37. Створена поштова наклейка може бути представлена в одному з наступних режимів:

Ø Предварительный просмотр;

Ø Конструктор.

38. Для додаткових настроювань і редагування виконайте перемикання відображення наклейки в режимі конструктора.

39. Виконайте збереження поштових наклейок.

40. Для печатки поштових наклейок необхідно виконати наступну послідовність дій.

40.1. Перед печаткою поштові наклейки необхідно перевірити в режимі попереднього перегляду;

40.2. Якщо зовнішній вигляд поштової наклейки влаштовує, для печатки скористайтеся одним з наступних способів:

40.2.1. I спосіб (печатка всіх сторінок поштових наклейок за замовчуванням).

40.2.1.1. На панелі інструментів виконайте фіксацію на кнопці “Печать” (Print).

40.2.2. II спосіб (печатка вибраного діапазону сторінок поштових наклейок).

40.2.2.1. У пункті меню “Файл” (File) активізуйте команду “Печать” (Print);

40.2.2.2. У діалоговому вікні “Печать” (Print), що відкрилося, здійсніть відповідні установки й виконайте фіксацію на кнопці “Ok”(для відмови від початку процесу печатки виконайте фіксацію на кнопці “Отмена”).

41. Створені поштові наклейки представте викладачеві для оцінки Вашої роботи.

42. Закрийте файл БД.

43. Вийдіть із Microsoft Access.

44. Виключіть ПК (за вказівкою викладача).

45. Оформіть дану роботу.

Питання та завдання для самоконтролю

1. Як здійснюється одержання інформаційної допомоги по тематиці даної роботи?

2. Якими способами можна відкрити діалогове вікно “Новий звіт”?

3. Якими способами можна скористатися для створення Звіту?

4. Методика створення звіту за допомогою Майстра звітів, в основі якого не використовуються поля із числовими даними.

5. Якими способами можна скористатися для здійснення збереження Звіту?

6. Які режими подання Звіту й способи переходу з одного режиму відображення звіту в інший?

7. Якими способами можна скористатися для здійснення закриття Форми?

8. Методика створення звіту за допомогою Майстра звітів на основі зв’язаних таблиць із використанням полів із числовими даними.

9. Яка елементна база вікна звіту в режимі конструктора?

10. Якими способами можна скористатися для зміни ширини й висоти звіту?

11. Якими способами можна скористатися для зміни розмірів полів?

12. Якими способами можна скористатися для переміщення полів і елементів полів?

13. Якими способами можна скористатися для зміни розмірів полів, вирівнювання, і зміни проміжків між елементами полів?

14. Методика відображення відповідних панелей інструментів, режиму конструктора й функціональне призначення кнопок даних панелей.

15. Якими способами можна скористатися для відображення Панелі елементів і функціональне призначення кнопок даної панелі?

16. Методика зміни напису для поля.

17. Методика вставки заголовка нового поля.

18. Методика вставки обчислювального поля.

19. Якими способами можна скористатися для уведення формул?

20. Методика створення й впровадження у звіт ілюстрації або малюнка.

21. Методика редагування нумерації сторінок звіту.

22. Якими режимами можна скористатися для попереднього перегляду звіту?

23. Методика підготовки й печатки звіту.

24. Методика створення Автоотчетов.

25. Методика створення стандартних поштових наклейок.

26. Методика створення нестандартних поштових наклейок.

27. Якими способами можна скористатися для здійснення збереження поштових наклейок?

28. Які режими подання поштових наклейок і способи переходу з одного режиму відображення в інший?

29. Якими способами можна скористатися для печатки поштових наклейок?


Практичне заняття №9

Тема дисципліни: Microsoft Office. СУБД Access.

Тема заняття: Робота з системою управління базами даних (СУБД) Access.

Мета заняття: Закрипіти теоретичні знання студентів і набути практичні навички роботи з імпорту даних у СУБД Access і експорту даних із СУБД Access у різні додатки MS Office

Тривалість: 2 години.

Порядок виконання роботи

1. Увімкніть ПК.

2. Виконайте запуск Access.

3. При необхідності виконайте пошук інформаційної допомоги по тематиці даної роботи.

4. Виконайте активізацію Вашого файлу Бази Даних.

5. Імпорт даних з Microsoft Excel.

6. Завдання: Створену в MS Excel таблицю необхідно імпортувати в Access для подальшої обробки.

Примітки: Імпорт даних в Access виконується в тому випадку, якщо дані відповідним чином розбиті на стовпці й рядки. Перший рядок даних може містити заголовки стовпців (Access використовує їх як імена полів) або ж значення.

Якщо в першому рядку знаходиться інша інформація, то при імпорті можуть виникнути проблеми. Саме із цієї причини рекомендується попередньо відкрити електронну таблицю й перевірити, чи підходить вона для імпорту.

Якщо імпортований аркуш робочої книги Excel має зайві заголовки й іншу непотрібну інформацію, то створіть спочатку іменований діапазон для частини електронної таблиці, у якій утримується корисна інформація.

7. Для рішення поставленого завдання необхідно виконати наступну послідовність дій.

7.1. Згорніть вікно Microsoft Access.

7.2. Здійсніть запуск Microsoft Excel.

7.3. На першому аркуші Excel створіть таблицю, що містить наступні стовпчики й уведіть 5-10 довільних записів.

  A B C D E F G
  Табельний номер   Прізвище Ім’я По батькові   Посада Оклад Дата прийому на роботу
Сидоренко Іван Петрович Директор 1500,00 12,01,2008
             
             
             
             

7.4. Збережіть створений файл на диску C:\Мои документы\Папка з шифром Вашої групи\, використавши в імені файлу тільки латинські символи, наприклад, Personnel1;

7.5. Згорніть Microsoft Excel.

7.6. Розгорніть Microsoft Access.

7.7. Для імпорту таблиці Excel у файл бази даних під ім’ям, наприклад, Personnel1 необхідно виконати наступну послідовність дій.

7.7.1. У пункті меню “Файл” (File) виконайте фіксацію на команді “Внешние данные” (Get External Data) і в підменю, що відкрилося, на команді “Импорт” (Import)”;

або

у межах робочої поверхні вікна Бази даних виконайте фіксацію правої кнопки миші й у контекстному меню, що відкрилося, виконайте фіксацію на команді “Импорт” (Import);

7.7.2. У діалоговому вікні “Импорт”(Import), що відкрилося:

7.7.2.1. У списку поля “Тип файла”(Files of type),що розкривається, де перебуває список доступних для імпортування форматів файлів, виконайте фіксацію на пункті “Microsoft Excel (*.xls)”;

7.7.2.2. У полі “Папка” виконайте установку папки, де розміщений створений в Microsoft Excel файл, у нашім прикладі C:\Мои документы\Папка з шифром Вашої групи\;

7.7.2.3. У робочій поверхні вікна виконайте маркування файлу, який треба імпортувати, у нашім прикладі Personnel1;

7.7.2.4. Виконайте фіксацію на кнопці “Импорт” (Import).

7.8. Відкривається діалогове вікно “Импорт электронной таблицы”, у якому за кілька кроків Майстер імпорту електронної таблиці (Import Spreadsheet Wizard) допоможе перетворити Excel-Дані в таблицю Access.

7.8.1. На першому кроці вибирається потрібний об’єкт.

7.8.1.1. В області, розміщеної у верхній частині вікна пропонується вибрати аркуші робочої книги або іменований діапазон:

Ø Листы;

Ø Именованные диапазоны.

Виконайте активізацію перемикача обраного варіанта, у нашім прикладі “Листы”;

7.8.1.2. У полі виконайте маркування аркуша робочої книги, на якому розміщена таблиця, у нашім прикладі Лист1 (Sheet1);

7.8.1.3. Виконайте фіксацію на кнопці “Далее” (Next).

7.8.2. На другому кроці вказується використання даних з першого рядка як імена полів таблиці.

7.8.2.1. У нашім прикладі, включіть вимикач “Первая строка содержит заголовки столбцов” (First Row Contains Column Headings);

7.8.2.2. Виконайте фіксацію на кнопці “Далее” (Next).

7.8.3. На третьому кроці встановлюється місце розміщення імпортованих даних.

7.8.3.1. В області “Данные необходимо сохранить:” пропонується два варіанти розміщення імпортованих даних:

Ø В новой таб