Створення гіперпосилань

Гіперпосилання використовуються з метою встановлення зв'язку між файлами різних додатків ОС Windows у мережі Internet або внутрішньої мережі підприємства.

Гіперпосилання - це текст, виділений іншим кольором і підкресленням, або графічний об'єкт, після активізації якого виконується перехід до файлу, адресу якого визначає Гіперпосилання.

У СКБД Microsoft Access Гіперпосилання можна створювати в таблицях, включати у форми та звіти, використовувати в таких елементах керування, як кнопки. Для створення гіперпосилань у таблиці необхідно:

1. Відкрити таблицю у режимі конструктора.

2. Створити нове поле (вводять ім'я, наприклад, «інформація»), надаючи йому тип Гіперпосилання.

3. Відкрити таблицю у режимі таблиці, встановити курсор у місце введення значень і ввести текст гіперпосилань (наприклад, "Документи Word" , "Таблиця Excel", тощо), як наведено на рис. 8.

4. Активізувати контекстне меню правою клавішею миші і вибрати у ньому команди Гіперпосилання -> Зміна гіперпосилання. Внаслідок цього на екрані з'являється вікно Зміна гіперпосилання (рис. 9), в якому у полі Введіть ім'я файла або Web-сторінки потрібно ввести ім'я потрібного файла (і, якщо необхідно, шлях) або, використовуючи кнопку Файл, у переліку дисків, папок, файлів, вибирають потрібний файл та активізують кнопку ОК. Адреса файла з'являється у полі вікна, після чого знову активізують кнопку ОК.

Після визначення файла достатньо в режимі таблиці активізувати гіперпосилання і потрібний файл завантажується.

Створення гіперпосилань - №1 - открытая онлайн библиотека

Рис. 8. Таблиця Покупці із створеними гіперпосиланнями

Гіперпосилання можна створювати у формі. Для цього потрібно відкрити форму у режимі конструктора і в меню Вставка вибрати команду Гіперпосилання. Внаслідок цього з'являється вікно Додання Гіперпосилання, в якому аналогічно вищеописаному потрібно визначити потрібний файл.

Створення гіперпосилань - №2 - открытая онлайн библиотека

Рис. 9. Діалогове вікно Зміна гіперпосилання

Тепер для активізації гіперпосилання v формі досить клацнути мишею на створеній кнопці.

Експорт даних

Експорт даних використовується з метою обміну даними між додатками Windows, створення таблиць у документах Word, електронних таблиць Excel, а також створення Web-сторінок на основі існуючої інформації БД Access.

Якщо, наприклад, треба створити файл формату Excel на основі даних запиту, то для цього виконують такі дії:

1. Активізують потрібний об'єкт в основному вікні БД (наприклад, таблицю Реалізація).

2. В меню Файл вибирають та активізують команду Експорт.

3. На екрані з'являється вікно Експорт об'єкта: Таблиця "Реалізація" в ... , в якому: активізують диск і папку, де зберігатиметься файл; у списку Тип файла вибирають Microsoft Excel 95-2000; активізують параметр Зберегти формат для збереження існуючого формату таблиці; активізують параметр Автозавантаження для автоматичного завантаження відповідного додатка (Excel) і відкривання в ньому таблиці; активізують кнопку Зберегти.

Внаслідок цього на екрані з'являється таблиця файла Excel, що містить значення таблиці Реалізація.

Аналогічно можна експортувати об'єкти БД у файли інших додатків. Для цього у вікні Експорт об'єкта у списку поля Тип файла вибирають потрібний тип файла. Всі інші дії виконують аналогічно описаним вище.

Імпорт даних

Користуючись засобами СКБД Microsoft Access, можна перетворити таблицю будь-якого формату (таблицю Word, таблицю Excel, тощо) на таблицю БД.

Якщо потрібно імпортувати будь-яку таблицю Excel у таблицю БД Access, то необхідно виконати такі дії:

1. Відкрити основне вікно БД Realiz.mdb.

2. В меню Файл вибрати команду Зовнішні дані-> Імпорт.

3. У вікні Імпорт: в полі Тип файлів із переліку вибрати Microsoft Excel; у переліку файлів типу.хls вибрати потрібний; активізувати кнопку Імпорт. Після чого з'являється вікно Імпорт електронної таблиці.

4. У вікні Імпорт електронної таблиці визначають, що імпортується: вся таблиця (вибирають потрібний листок) чи тільки діапазон значень. Після цього активізують кнопку Далі. У наступному вікні визначають, чи є перший рядок рядком заголовків полів таблиці. Якщо перемикач є неактивним, то назви полів створюються автоматично (Поле1, Поле2 тощо). Якщо перемикач активний, то активізуємо кнопку Далі. У наступному вікні визначають місце збереження даних (у новій таблиці або в існуючій). Натискаємо кнопку Далі. У наступному вікні визначають ті поля, які не потрібно імпортувати. Для цього виділяють поле, активізують перемикач не імпортувати. В цьому вікні можна також змінити ім'я поля, для чого в поле Ім'я поля вводять інше ім'я. У наступному вікні визначають наявність і тип ключового поля в таблиці, яку буде створено. Для створення поля типу лічильника активізують перемикач Автоматично створити ключ, а також кнопку Далі. В останньому вікні визначають ім'я таблиці, що створюється, та активізують кнопку Готово. Після чого з'являється повідомлення, що імпорт закінчено.

У режимі конструктора можна переглянути типи полів, які система встановила автоматично.



Завдання для практичної та самостійної роботи

Задача: Завод молочних продуктів виготовляє продукцію п'яти найменувань і реалізовує її за ціною, наведеною в табл. 1. За допомогою СУБД Access створіть базу даних Realiz.mdb, яка б передбачала:

> ведення довідника продукції;

> ведення довідника покупців;

> облік реалізації.

Таблиця 1.

Створення гіперпосилань - №3 - открытая онлайн библиотека

1. Запустіть програму для опрацювання бази даних Access.

2. Створіть нову базу даних з іменем файлу - Realiz.mdb.

Діалогове вікно Access -> Нова база даних -> ОК -> виберіть свою папку, дайте назву файлу -> Створити.

3. Створіть таблицю Міста шляхом вводу даних з такими полями: КодМіста, НазваМіста.

На панелі об'єктів клацнути лівою клавішею миші на ярлику Таблиці:

- В робочому полі вікна вибрати ярлик Створення таблиці шляхом вводу даних і два рази клацнути на ньому лівою клавішею миші. Після цього з'явиться порожня таблиця зі стандартними назвами стовпців. Поле1, Поле2, ..., Поле3.

- В перший рядок Поля 1 введіть - Київ; у другий рядок Поля2 запишіть Луцьк і т д.

- Тепер перейменуємо заголовок стовпця Поле1 на НазваМіста. Це можна зробити за допомогою контекстного меню, або меню програми (Формат -> Перейменувати стовпець), попередньо позначивши необхідний стовпець.

- Після цього необхідно зберегти таблицю (Файл -> Зберегти), і в діалоговому вікні Збереження ввести ім'я таблиці - Міста ОК.

- На запит Створити ключове поле зараз дати відповідь Так.

Створення гіперпосилань - №4 - открытая онлайн библиотека

Рис. 10. Таблиця Міста в режимі таблиці

- Виділити в списку таблицю Міста і натиснути кнопку Відкрити, що на панелі інструментів вікна бази даних. Відкриється таблиця, яка повинна виглядати аналогічно таблиці, яка представлена на рис. 10.

4. Створіть таблицю Продукція за допомогою Майстра з такими полями: КодПродукції, НазваПродукції, Ціна.

На панелі об'єктів, клацнути лівою клавішею миші на ярлику Таблиці

- Вибираємо режим Створення таблиць за допомогою майстра. Після цього з'явиться діалогове вікно Створення таблиць (рис. 11). Встановіть у ньому перемикач Ділові, а в списку Зразок таблиць виділіть таблицю Товари.

- Зі списку Зразки полів вибрати всі необхідні поля (а саме КодТовару, Опис товару, Ціна) і перенести їх в список Поля нової таблиці. Це робиться за допомогою кнопок зі стрілками між цими списками Кнопка > дозволяє переміщати поля по черзі у вибраному порядку.

Створення гіперпосилань - №5 - открытая онлайн библиотека

Рис. 11. Діалогове вікно Майстра таблиць

При бажанні включити в свою таблицю всі поля зразка потрібно натиснути на кнопку ». Якщо Ви перемістили поле, а потім передумали, можна відмовитися від свого вибору, використовуючи кнопки з протилежними стрілками.  За допомогою кнопки Перейменувати поле... можна змінити назви полів. Якщо вибрані всі необхідні поля, натиснути кнопку Далі.

- В діалоговому вікні, яке з'явиться, необхідно вказати ім'я таблиці і спосіб визначення ключа (можна залишити так, як пропонує майстер). Після цього знову натисніть кнопку Далі.

- На наступному кроці майстер пропонує встановити зв'язок з іншими таблицями. В нашому випадку поки що зв'язки робити немає потреби, тому натискаємо кнопку Далі.

- На останньому кроці Майстер пропонує визначити дії після створення таблиці. Встановіть перемикач на Змінити структуру таблиці і натисніть кнопку Готово. Таблиця Продукція відкриється в режимі Конструктора, де можна побачити її структуру, тобто перелік полів і властивості кожного поля.

5. Виберіть режим Конструктора і створіть таблицю з назвою Покупці з полями: КодПокупця, НазваПокупця, Місто.

- Клацнувши двічі по ярлику Створення таблиць в режимі Конструктора, відкриється порожнє вікно Конструктора таблиць, в якому потрібно визначити структуру таблиці Покупці.

- У верхній частині вікна Конструктора міститься таблиця, яка складається з трьох стовпців: у стовпці Ім'я поля, вводяться імена полів; у стовпці Тип даних потрібно задати тип даних, для кожного поля, методом вибору із запропонованого списку; і в третьому стовпці Опис можна ввести інформацію про дане поле, але він є необов'язковим. В нижній частині вікна задаються властивості полів таблиці (рис. 3).

- Для поля КодПокупця встановіть Тип даних Лічильник, який автоматично кожному покупцеві буде присвоювати унікальний код (значення якого буде на 1 більше попереднього). Для поля НазваПокупця встановіть Тип даних - Текстовий, а для поля Місто виберіть у списку тип даних Майстер підстановок...

Для створення стовпця підстановки потрібно виконати таку послідовність дій:

1. У таблиці Покупці, у стовпці Тип даних, поля Місто вибрати зі списку Майстер підстановок...

2. У діалоговому вікні Майстра підстановок, встановіть перемикач Об'єкт "стовпець підстановки" буде використовувати значення з таблиці або запиту, тому що в цьому випадку ми повинні використовувати дані з таблиці Міста. Натисніть кнопку Далі.

3. У наступному діалоговому вікні виберіть таблицю Міста і натисніть кнопку Далі.

4. У списку Доступні поля виводяться всі поля таблиці Міста (Код та Назва міста). Перемістіть необхідні поля в список Вибрані поля і натисніть кнопку Далі. В нашому випадку необхідно перемістити обидва поля.

5. У наступному діалоговому вікні є можливість заховати ключовий стовпець, який містить коди, та відрегулювати ширину стовпця. Встановивши потрібну ширину стовпця, та поставивши галочку навпроти Заховати ключовий стовпець натисніть кнопку Далі.

6. В останньому діалоговому вікні введіть підпис для поля Місто і натисніть кнопку Готово. На запитання Чи зберегти таблицю перед створенням зв'язку, відповісти так. (Після цього Access автоматично створить зв'язок між таблицями Покупці і Міста).

7. Перед тим, як зберегти таблицю, необхідно визначити в ній ключове поле. Для цього потрібно виділити поле, яке буде ключовим і на панелі інструментів натиснути на кнопку з відображенням ключика. Збережіть таблицю під іменем Покупці.

6. За допомогою Конструктора створіть таблицю з назвою Реалізація, з полями: Дата, Покупець, Продукція, Кількість (рис.13).

Для поля Кількість надати тип даних Числовий, а для полів Покупець і Продукція створити стовпці підстановки. Полю Дата задати тип даних -Дата/Час, у властивостях Формат поля вибрати - Короткий формат дати і за допомогою Майстра задати маску вводу (маска вводу забезпечує можливість вводити тільки цифри, а інші символи (-, /, .) будуть добавлятись автоматично).

Щоб задати маску вводу, потрібно натиснути кнопку з трьома крапками справа (…) у властивостях Маска вводу. Після цього Access буде вимагати зберегти таблицю. Після підтвердження зберігання таблиці на екрані з'явиться діалогове вікно Майстра, в якому виводиться список стандартних масок для полів дати і часу (рис. 12). Цей список можна доповнювати або робити зміни. В ньому вибираємо Короткий формат дати (00.00.00) і натискаємо кнопку Готово.

7. Відкрийте створену таблицю Продукція в режимі таблиці і введіть п'ять даних найменувань і їх ціну.

8. В таблицю Покупці введіть не менше ніж п'ять назв покупців (в ролі покупців можуть бути магазини, бари, кафе і т. п.).

9. В таблицю Реалізація введіть довільну інформацію з реалізації продукції (але не менше як 20 записів). Збережіть дані.

Створення гіперпосилань - №6 - открытая онлайн библиотека

Рис. 12. Діалогове вікно Майстра масок вводу

Для введення або доповнення записів у таблицю потрібно натиснути на кнопку створення нового запису, або в меню Вставка вибрати команду Новий запис.

10. Заховайте перший стовпець.

11. Поновіть перший стовпець на екрані.

12. Вилучіть другий запис із таблиці.

13. Доповніть таблицю ще двома записами.

14. Відредагуйте деякі записи в таблиці

15. Впорядкуйте введені записи за зростанням значень поля Дата.

16. Впорядкуйте записи за спаданням значень поля Кількість.

17. Відшукайте в таблиці Реалізація продукцію, в якої назва відома або

відомі лише перші три (чотири) символи.

18. За допомогою фільтрів відшукайте всіх покупців, які купували Молоко.

Ставши на запис Молоко в полі Продукція, натиснути кнопку Фільтр за виділеним.

19. Закрийте свою БД, зберігаючи дані на диску.

Створення гіперпосилань - №7 - открытая онлайн библиотека

Рис. 13. Таблиця Реалізація

Створення гіперпосилань - №8 - открытая онлайн библиотека

1. Що таке база даних?

2. Яке призначення програми Access?

3. 3 чого складається база даних?

4. Що таке запис?

5. Як створити базу даних?

6. Що таке структура таблиці бази даних?

7. Які є властивості полів?

8. 3 чого складається таблиця бази даних?

9. Які об'єкти може містити файл бази даних?

10. Яке призначення баз даних?

11. Що таке поле?

12. Які є типи полів?

13. Як створити структуру бази даних?

14. Що означає модифікувати структуру бази даних?

15. Як ввести дані у базу даних?

16. Як сховати чи показати стовпці в таблиці?

17. Як вставити нове поле в структуру?

18. Як вилучити запис із таблиці?

19. Як відсортувати записи?

20. Яке призначення конструктора таблиці?

21. Як вилучити поле зі структури таблиці?

22. Як ввести в таблицю новий запис?

23. Які види сортування Вам відомі?

24. Як змінити назву поля в таблиці?

25. Як збільшити шрифт під час введення даних у БД?

26. Яким способом задають тип поля?

27. Яка різниця між назвою файлу БД і назвою таблиці цієї БД?

28. Зі скількох таблиць може складатися база даних?

29. Яка різниця між записом і полем?

30. Яке призначення фільтрів?

31. Для чого призначена команда Застосувати фільтр?

32. Яке призначення команди Відмінити фільтр?

33. Що таке реляційні таблиці?

34. Як налаштовувати реляційні зв'язки?

35. Яке призначення ключового поля?

36. Як вилучити зв'язок таблиць?